Jump to content
Corsair Community

800D sticky power button a tale of woe


rrrush1

Recommended Posts

This is a new build and every thing went well until I buttoned it up.then it got erratic on start up.sometimes it would boot and sometimes it would start to boot and then cut out.I disconnected one thing at a time ,couldn't find it.I removed motherboard and a minimum bench setup.it worked so I added one part at a time until I had it fully assembled out of the case.surfed the net. turned it on and off a large number of times and it worked perfect,but I didn't find the problem,which meant I didn't fix it.I assembled back in the case one piece at a time and it worked but I still didn't know what the problem was.Than it started acting up again.[ I used this computer for two days out of the case,a OK ] I started taking it apart again in reverse order.the last thing I put on was the front panel so i took it off and it was OK.I Checked power button and it was slow to release and sometimes it was just stuck.I made a temp. repair by breaking one of the plastic pieces. [ that act as a return spring ] and repositioned it.it works now but for how long?

Can I get a replacement button assambly that's plastic welded to the front of the case.I can install it myself.I don't want to send the front panel back.

I also installed a H100 CPU cooler that didn't work right but thats a story for another time

Link to comment
Share on other sites

I am impressed.corsair responded to my problem with a free new front panel shipped free. They gave me a cupon code that took care of everything.now thats what I call service.

 

 

I found this via Googling for the same problem, the sticking button that is, I didn't temp break anything, it just fell apart on me, case is maybe 8 months give or take old. My power button had stuck for a bit, usually wiggling it some would fix it, and today it just snapped! Found all the pieces intending to try to superglue fix it, but had a bezel connector break on me when I took the case off, and the reset piece to connect IT to the little button fell off as well =( Please Corsair gods help a brother out? I wish the mobo had a power on switch like my evga board did, then I wouldn't care, but it doesn't and I can't get to the little button to turn the rig on! <3

 

http://i6.photobucket.com/albums/y245/Midknight00711/FrontPanel.jpg

 

See how the button snapped of the little springy plastic arms? Ignore the screws, they're just there because the backdrop makes it easier to see the pieces. I was going to take the pic on my Corsair power supply's box, but I didn't want to be that blantantly begging for help ;)

Link to comment
Share on other sites

  • 1 month later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...