Jump to content
Corsair Community

M60 Stuttering/Stopped working - Solved


Crazy Chuckster

Recommended Posts

Just wanted to put this out there for users having any issues with their M60 mouse. I got my brand new M60 today from Newegg and hooked it up to my rig and installed the newest software. After making some DPI changes and checking the surface quality the mouse started stuttering really bad.

 

Next thing I notice is the left and right clicks not registering. So I unplug it and come on here looking for a solution. I happen across this post by RamGuy

 

Please flash the mouse firmware:

 

M60:

http://www2.corsair.com/software/M60_90/M60110711v107.zip

 

M90

http://www2.corsair.com/software/M60_90/M90110211v108.zip

 

Note: this is a flash of the current firmware and not an update.

 

I plugged in a second mouse with my M60 still plugged in and ran the updated firmware. Voila! All is good, at least for now. I played a good couple hours of BF3 and I have to say I am pretty impressed with this mouse so far.

 

It is comfortable, buttons have good feel, pointer does not move when lifting and it glides suuuper smooth on my C4Ngen mouse pad.

 

Software is not over bearing, the only other features I could see to need in the software is options for disabling mouse acceleration.

 

 

I feel as though I have a keeper here to replace my old logitech products. I tried the Rat and was not happy.

 

Thanks Corsair for a good solid performing product. Once the software gets to 100% I feel you will have a real competitor for gamers here.

Link to comment
Share on other sites

  • 3 months later...

I'm having the exact same issue........

All buttons on the device work but no tracking at all. I have updated firmware and have tried on a different system and still the tracking does not work.

 

Is this a common problem with these devices? because I need a reliable mouse.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...