Jump to content
Corsair Community

Can't update my SSD?


lukehoare

Recommended Posts

OK, instead of making a new thread I thought I'll post in this as I get same error.

 

Drive in question: Corsair Force GT 120GB, FW 1.2

 

First of some info:

- BIOS set to AHCI prior to install

- Flash utility run as admin

- Fresh install today, error prior to reinstall and still.

- Downloaded Firmware from website for my drive.

- All windows updates and drivers installed and applied.

- Drive connected to native SATA3 port controlled by AMD southbridge

-- see rest of system specs in my profile, should all be there.

 

Today I got my 2nd Corsair Force GT 120GB drive. The new had firmware 1.3.3 already installed so I wanted to update the "old" drive to the same, right now it has 1.2.

 

However, even though i followed the instructions it imidiatly fails with above mentioned error code.

 

Old drive is called "Corsar Force GT SSD", new is called "Corsair Force GT" .. don't know if this is due to FW difference.

 

I did double check the signature and did pick the right file (22757).

 

screen snipping: http://pastebin.djabba.eu/capture2.png

 

any suggestions?

Link to comment
Share on other sites

oh, and before anyone suggest to use the contact/rma form .. i tried that.

 

all i got from that was after spending a lot of time filling it out with as many details as possible to provide as accurate a situation assesment as possible ... pressing the submit button and getting told "your login has timed out, try again" ..

 

all infos was gone from the input fields, on top of that, i wasn't even logged into anything to begin with nor do you have to be to use the form.

 

All i want to do is flash my drive .. can't be so hard to make a tool for that .. though it seems it is after reading through these forums....

Link to comment
Share on other sites

Ok, little update.

 

-Roll back drivers for sata : unsuccesfull, rolled back to version 1.2.001.0275 AMD driver.

 

However, this does not seem to be a corsair problem. I thought, as not told otherwise anywhere, that the firmware updater was a corsair tool. It is not. Its a SandForce tool and it is that that is buggy.

 

Reason for buying my 2nd Force GT was to free up my old ******** Pyre 60gb with async flash and move that to my htpc where it doesn't matter. Before doing so I ofcourse wanted to update the FW on that as well. As i downloaded that i found out that the Pyro uses the exact same tool just with a different image header.

This however, was also unssucessfull. It takes longer to fail, but fails with the same error message.

 

Is there any other update tool besides this non-working SandForce windows fail-tool? download page only offers that.

 

[Edit]

Ok, your hunch/knowledge was right .. it is a AHCI driver issue with the AMD drivers (though claimed to work) ... or part of the problem.

 

Went trough all my other systems (only got AMD) until I found one with default AHCI drivers and flashed both my Pyro drive and the "old" Force GT.

Both times it came up with "success", however firmware didn't change. Rebooted manually after each update and switched drive. Checked both drives in another comp, FW is still on the old version on both.

Link to comment
Share on other sites

i did it one at a time, it's my NAS system (AMD A6-3500 powered, win7 64bit sp1) and it only has 1 free port atm of the onboard sata 6g port.

First i tried updating my pyro drive because it already was build out of my main system, as stated it indicated success but didn't show any difference in the firmware-tool. I assumed i needed a reboot for windows to recognize it, so just shut down the system manually and removed the drive.

I attached the Corsair Force GT 120gb instead and rebooted and did the same. Again it reported success but no change in firmware.

 

This is when i got suspicious. Took them 1 by 1 and attached to my main system again to verify if changed or not. Both disks still reported the old firmware on main system as well.

 

Just to provide all infos, all other drives in the NAS system are "old" mechanic drives, so there was only 1 ssd present during the flashing.

Link to comment
Share on other sites

Question to the "pro" people here, there is no problem in attaching the SSD to an eSATA dock, right? Cause I also got a Zotac ID40 miniPC with an atom d525 cpu (so assuming it has intel sata without checking now).

Logically it only has 1 internal port (and will need that for OS drive) as its a miniPC, but it has eSATA.

Anything speaking against using eSATA to flash the drive? Shouldn't, as eSATA just is an extension cable from the principle. Its only a sata2 system though, but guessing this wont matter either to flash a drive?

I rather ask then brick my drives :)

Link to comment
Share on other sites

Thank you Yellowbeard, couldn't see why it shouldnt work (at least if the specs are as they should be). eSATA is just an extention cord with an external power supply, no controller or anything between.

Will try to see if I have luck updateting via the Atom based miniPC then

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...