Jump to content
Corsair Community

SSD Firmware Tool shows 1.3 (not 1.3.3)


USMC_Vet

Recommended Posts

Hi everyone.

 

I have searched through this whole forum for a few days,

I do apologize if I missed this answer somewhere.

 

When I ran the Corsair Firmware Update Tool to update to 1.3.3:

 

I got the green checkmark, however the FW rev number only says 1.3?

 

The signature is 142-142-22790.

 

Should it say 1.3.3?

 

My system is still a bit unstable and Im hoping this is the culprit.

 

Thank you all for your help.

Link to comment
Share on other sites

  • 2 months later...

*Bump* *Bump* *Bump* *Bump*

 

Edit: Found a solution that worked for me: http://www.tomshardware.co.uk/forum/286130-12-ahci-drivers#t1959235. If the link is dead, go to http://support.microsoft.com/kb/922976, download and run script. Reboot, and enable AHCI in bios (for me (ASUS) like this http://www.youtube.com/watch?v=Bn0XTsIXQiA). Reboot, and run Firmware updater again.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...