Jump to content
Corsair Community

Corsair Force 3 90 GB SSD (f/w 1.3.3) reading as only 33.8 GB


Recommended Posts

Hi people.


After having my 90Gb SSD for a few weeks, I got around to installing it. Performance was poor unfortunately, and it wouldn't go above 150MB/s sequential read, even on the marvell SATA3 connector on my Gigabyte X58a-UD3r, but that did provide the best performance.


Anyway, I had an issue with my Raid1 HDD array at the same time and went to update the firmware on a pair of 'different brand' drives to resolve known issues. It turned out one of the drives was on its way out anyway, but then I noticed this after booting:




I admit it was probably very foolish of me to leave the drive connected, but as this firmware update utility ran immediately after the next reboot the update went ahead on my array before I could do anything. The updater itself reported the Force 3 drive was connected, and also said it did not attempt any update on it.


Is there a way to reset this drive's size? I'm still new to SSD but know my way around bios etc. I've tried different drivers, reflashing the 1.3.3 firmware, AHCI windows drivers. Tried in Jmicron, Marvell and ICH10R controllers and no change!


The 'fitness' and 'performance' levels are getting lower on speedfan's SMART rating system too. LBA Written attribute is at 63h and Read is at 8Fh (raw) which appear as something to watch, along with a load of unrecognised attributes.


I'm worried I've ruined it! Can you help?

Link to comment
Share on other sites

No it was the right amount at 90Gb when first installed but performed poorly with AHCI drivers as well as SATA/IDE modes. The 2 drives I updated were both 750Gb which were both 'unraided' to prevent any issues updating them. I think this needs an RMA sadly as even in bios it's showing up as ~33gigs and I can't even adjust any higher using manual lba/block settings etc. Unless any more suggestions come to light? I guess now that SMART attributes are being affected I should RMA... :(
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...