Jump to content
Corsair Community

Weird problems with vengeance 1500


eilert

Recommended Posts

Hello there.

 

I have this really weird problem with my new 1500 headset;

 

The headset works fine almost all the time, usually when I take the headset on and off sometimes I lose sound for like 3 seconds, and I hear the usb reconnects , a windows sound. When this happens i sometimes lose my connection with my mouse and I always lose the connection with the keyboard. Now normally I would think this is a mainboard problem, but the thing is I ordered a new motherboard, the exact the model, and the problem is still there, so I am literally out of ideas on how to fix this problem. These problem doesnt occur when my headset isnt connected.

I've formatted 3 times, using xp/win7 x64.

The problems are still there when I have the drivers installed and when it's not installed (and yes I have installed the drivers exactly how it's guided).

Now it feels like connection problems with the headset, but if that's so I cant figure or understand why my keyboard and mouse would reconnect aswell (Note these problems only occur when the 1500 is connected).

 

pc specs:

Intel Core i7 2600K

ASUS P8Z68-V PRO, Socket-1155

******** 2TB Green 3,5", SATA

******** ******** 8 GB-kit DDR3 1600 MHz x2

Chieftec, 750W, CFT-750-14CS, modulated

PowerColor Radeon HD 6970 2GB GDDR5

Qpad MK-50 keyboard USB

Microsoft SideWinder X3 Mouse USB (I have also tried with logitech mx518 and zowie EC1, still the same problems).

 

 

Is there anyone here who knows what to do? I would appreciate quick help with this.

 

 

Thanks.

 

 

EDIT;

 

I also have the newest bios update.

 

And another thing i've tried is this;

 

I went to device manager -> universal serial bus controllers -> properties -> power management -> allow the computer to turn off this device to save power (I turned off on everything)

 

Now i'm gonna try that for abit to see if it works, will write if it works or not.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...