Jump to content
Corsair Community

K90 G keys not working in LotRO


Recommended Posts

Picked up a K90 last week to replace a Razer Black Widow and get rid of the Logitech G13 that's taking up space on my desk. I updated the firmware and downloaded the latest software immediately, and tonight I finally got around to assigning the macros I use in LotRO to the G keys. I tested them in Notepad and they are definitely outputting the macros, but they do nothing when I get in-game. I tried hardware mode too, but that didn't help. Anyone else having the same problem with this game? Better yet, any solution to make them work?


edit: Forgot to say that I have 50ms delay between all key presses.

Link to comment
Share on other sites

Did you load the settings into your hardware playback by going into Manager Profiles and "Save to K90"?


No, I didn't realize I had to do this (I didn't even know Manage Profiles and Assign Keys were selectable, they don't look like tabs), but it worked after I saved the profile to the keyboard and enabled Hardware Playback.


I generally like Corsair products (see my system config) and you guys usually have good documentation, but you really need to work on the instructions for these new keyboards and mice. There's basically nothing in the box with the keyboard and the online FAQ's and directions are vague and not very useful. Also, the keyboard configuration panel looks nice, but using it is not intuitive. For example, I have no idea what the four buttons under "Playback Options" do. I know you're working on improvements, but just simple pop-up tool tips on all the buttons would help a ton, and also make your job on this forum easier by not having to answer basic questions like mine.


Thank you for your help, it seems to have solved the problem I was having.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...