Jump to content
Corsair Community

H80 Cooler performance low


Hedgehog33

Recommended Posts

Hi there, can any one help me out please?

 

I have just upgraded from the corsair H50 to the H80 and the CPU temp is a little high for a system that has not been overclocked. The spec on of my system is up to date, please see.

 

It currently idles between 34 and 35 degrees C with the fan speed set to max. From what i have read, this cooler should be cooling a lot lower than this. My dad is running with a Corsair A50 and his temp at idle is around 28 degress C.

 

According to the bios the pump is running at about 2k rpm.

 

Any surgestions please??

Link to comment
Share on other sites

Could be a bad mount. When i mount hydro units i use one hand to put pressure on the top of the pump/block assembly while i tighten the thumbscrew hold down in a criss cross pattern, maybe a full turn at a time until they are very tight.

 

Thats the way i installed the block. When you installed the back plate and pillers, did the piller tighten down onto the MB ok??

 

Once i tightened mine down, the plate could still move slightly but once the pump installed it did not move.

 

Also, what sort of temps are you getting?? I notice we have the same case, how are you case fan setup?? Thanks

Link to comment
Share on other sites

Fan setup is front intake, top exhaust, h60 exhaust with push/pull. Running 4.5 at the moment with 1.36v and very max temp is 67°... This is running linx, which is usually 2° hotter then prime95s max temp for me... Yes I had the play in the bracket as well. Im also running fans at 2000rpm on a fan controller.
Link to comment
Share on other sites

Fan setup is front intake, top exhaust, h60 exhaust with push/pull. Running 4.5 at the moment with 1.36v and very max temp is 67°... This is running linx, which is usually 2° hotter then prime95s max temp for me... Yes I had the play in the bracket as well. Im also running fans at 2000rpm on a fan controller.

 

Do you mean the fan controller on the case? If not which one do you have?

 

The 200mm fan i have only run at a max of around 800 RPM.

Link to comment
Share on other sites

Hedge, I can achieve sub 30C idle temps on an i7-2600K with a H60 (push-pull, intake.) The H60 has a PWM fan, controlled by the mother board, and at idle the fan is at ~850 RPM. I use all the power saving option, C1E, SpeedStep, and C-States set to C6. I'm still OC'd via Turbo multiplier, above 4.0GHz, but with the power saving options enabled at idle the CPU is at 1.6GHz. I also do not set Vcore to a fixed voltage, I leave it on Auto, which IMO helps keep the CPU cooler. I'm still able to idle at ~30C with none of the power saving option on, and no OC.

 

Are you using the H80 as exhausting air from the case, or intake? If you have it set up as exhaust, and your video card is near the H80 fan, the heat from the card might be raising your temps. Do you have the H80 mounted the same way as your H50?

Link to comment
Share on other sites

Hedge, I can achieve sub 30C idle temps on an i7-2600K with a H60 (push-pull, intake.) The H60 has a PWM fan, controlled by the mother board, and at idle the fan is at ~850 RPM. I use all the power saving option, C1E, SpeedStep, and C-States set to C6. I'm still OC'd via Turbo multiplier, above 4.0GHz, but with the power saving options enabled at idle the CPU is at 1.6GHz. I also do not set Vcore to a fixed voltage, I leave it on Auto, which IMO helps keep the CPU cooler. I'm still able to idle at ~30C with none of the power saving option on, and no OC.

 

Are you using the H80 as exhausting air from the case, or intake? If you have it set up as exhaust, and your video card is near the H80 fan, the heat from the card might be raising your temps. Do you have the H80 mounted the same way as your H50?

 

The fans are setup to draw are in from outside the case.

 

As for the mounting, I think they are slighly different but only in the way round the radiator is. The H50 had the pipes coming out of the top, now they are at the bottom.

 

I have just order some decent TIM as the other stuff i used was from PC World, sorry for swearing on a public forum!

 

Whats the best way to apply the TIM? before i have placed a small drop in the middle of the CPU but this time i spread it with a card.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...