Jump to content
Corsair Community

M60 Mouse and K60 Keyboard not working for MMO (SWTOR)


golightly

Recommended Posts

The M60 and K90 keyboard and mouse designed for MMO's does not work with the major MMO SWTOR. Even with the new beta drivers.

 

This is what happens when I try and use them together.

 

I've assigned the MMO mouse buttons to SHIFT+ALT+1, SHIFT+ALT+2 etc for mouse buttons no 7 to 15. I record using the MR button in the script, then clicking on the button to assign.. then pressing the keys that should be bound.

 

For some reason it records two of everything so it says under the Assign button Window Lshift twice, then 0.050 delay twice etc.. See enclosed image. Like so:

 

LShift

0.050 seconds delay

LShift

0.050 seconds delay

LAlt

0.050 seconds delay

LAlt

0.050 seconds delay

1

0.050 seconds delay

1

 

But to make those buttons work in my MMO (SWTOR) I have to delete one of each set, removing the duplicates so it says:

 

LShift

0.050 seconds delay

LAlt

0.050 seconds delay

1

 

I then start up the game client for SWTOR and start playing. But as soon as I press any of those mouse buttons that I have configured my M60 keyboard then stops working in as much that all the keys are reassigned. ESC becomes New window, A is H, Alt is 5 etc.. No keys are mapped correctly.

 

It happens as soon as I press any of the configured mouse buttons.

 

I then have to with the mouse close down the game client and then restart the computer and disconnect the mouse which I then proceed to throw in the bin.

 

Why does this happen?

mousebuttons.jpg.983d5b38976217fd19399baf32021deb.jpg

Link to comment
Share on other sites

The M60 and K90 keyboard and mouse designed for MMO's does not work with the major MMO SWTOR. Even with the new beta drivers.

 

This is what happens when I try and use them together.

 

I've assigned the MMO mouse buttons to SHIFT+ALT+1, SHIFT+ALT+2 etc for mouse buttons no 7 to 15. I record using the MR button in the script, then clicking on the button to assign.. then pressing the keys that should be bound.

 

For some reason it records two of everything so it says under the Assign button Window Lshift twice, then 0.050 delay twice etc.. See enclosed image. Like so:

 

LShift

0.050 seconds delay

LShift

0.050 seconds delay

LAlt

0.050 seconds delay

LAlt

0.050 seconds delay

1

0.050 seconds delay

1

 

But to make those buttons work in my MMO (SWTOR) I have to delete one of each set, removing the duplicates so it says:

 

LShift

0.050 seconds delay

LAlt

0.050 seconds delay

1

 

I then start up the game client for SWTOR and start playing. But as soon as I press any of those mouse buttons that I have configured my M60 keyboard then stops working in as much that all the keys are reassigned. ESC becomes New window, A is H, Alt is 5 etc.. No keys are mapped correctly.

 

It happens as soon as I press any of the configured mouse buttons.

 

I then have to with the mouse close down the game client and then restart the computer and disconnect the mouse which I then proceed to throw in the bin.

 

Why does this happen?

 

They are not duplicates. They are down and up commands. And you need them both.

 

What you need is:

Down LSHift

Down LAlt

Down 1

delay 50

Up 1

Up LAlt

Up LShift

 

That should work I think.

 

The reason everything gets weird is if you remove the UP commands the shift, alt and 1 key will be kept pressed down forever. Even after you released your mouse button. And that will mess with all other keyboard commands and so on.

 

It's like spilling Coke all over your keyboard.

Link to comment
Share on other sites

They are not duplicates. They are down and up commands. And you need them both.

 

What you need is:

Down LSHift

Down LAlt

Down 1

delay 50

Up 1

Up LAlt

Up LShift

 

That should work I think.

 

The reason everything gets weird is if you remove the UP commands the shift, alt and 1 key will be kept pressed down forever. Even after you released your mouse button. And that will mess with all other keyboard commands and so on.

 

It's like spilling Coke all over your keyboard.

 

The key does not work if I use what it recorded as I showed on the screenshot. How am I suppose to know that I have to remove the delays, keep only the one and have all the keys? That's just silly.

 

Oh and.. It's not possible to put it in that order as you suggested! It records it as I mentioned above and you can't move the order of those keys around and you can't press them in a way to make it become as you mentioned.

Link to comment
Share on other sites

The key does not work if I use what it recorded as I showed on the screenshot. How am I suppose to know that I have to remove the delays, keep only the one and have all the keys? That's just silly.

 

Oh and.. It's not possible to put it in that order as you suggested! It records it as I mentioned above and you can't move the order of those keys around and you can't press them in a way to make it become as you mentioned.

 

You do not have to remove the delays but they are not necessary.

 

Press and hold LShift, Press and hold LAlt and press and hold 1,

then release 1, release LAlt, release LShift.

 

Doesn't that work?

 

And don't blame me for the software. I'm just trying to help you.

Link to comment
Share on other sites

You do not have to remove the delays but they are not necessary.

 

Press and hold LShift, Press and hold LAlt and press and hold 1,

then release 1, release LAlt, release LShift.

 

Doesn't that work?

 

And don't blame me for the software. I'm just trying to help you.

 

No it doesn't work and like many other users have reported they can't get it to work. I've now returned my mouse and getting my money back. I'm buying something that works rather than spending money on a faulty product.

 

I do know you're trying to help which is very nice of you but no one who buys a released product should have to use work-around and jump through hoops to get it to work. This product should work out of the box or it should NOT have been sold in the first place. Corsair is breaking European consumer laws by shipping this rubbish and selling a product that does not work for it's intended purpose.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...