Jump to content
Corsair Community

120GB Force 3 Works ok on some motherboards?


Recommended Posts

I purchased a 120GB Force 3 SSD for my system a couple of weeks ago. It was in the system less than an hour when my HDD Health monitor started alerting me to a fluctuating SMART reading. At the time I considered it may just be that the program wasn't designed to work with SSDs so I ignored it thinking, the drive is new, it can't pack in that quickly surely. However, within 16 hours of active drive time my PC hit a blue screen of death. After restarting, my BIOS was unable to detect the SSD.


At this point, I came to these forums in search of answers. Sadly the first posts I read indicated that even Corsair themselves were aware of issues with this product. However, I tried a few of their suggestions such as replacing the SATA lead, changing the connection on the board, trying another power connector from my PSU, adjusting the PCH, changing controllers etc... Nothing changed, the drive was totally dead as far as BIOS was concerned.


Left with little option, I reported the fault to the company from where I had purchased the drive to see about returning it as faulty. I also decided, after reading the errors reported on this forum, that I would not accept an exchange for the same drive again. They arranged a courier to collect the drive and return it to them for testing.


I've now found that they've connected the drive and it's working 'fine' for them apparently. Supposedly they have no SMART warnings and have been able to transfer 140GB worth of data on/off of the drive without any issues...


This leaves me in a very awkward position as I know for a fact the drive was not functioning on my end, so either they are simply lying so they don't have to give my money back, or this comes down to my motherboard (ASUS Sabertooth P67 R3) not liking the drive but the motherboard they've tested it on is ok with it.


Would I be wrong to assume that the latter may be correct? Does this drive work fine on some motherboards but not on others? Has anybody actually tried the drive on an ASUS Sabertooth P67 R3 board and if so, what were the results?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...