Jump to content
Corsair Community

K90 keyboard not working at all....


Recommended Posts

so.. i plugged it in without drivers, and software... they keyboard lit up beautifully and the media keys worked fine.


i realise im gonna have to download the software anyway, to get the G keys to work. so i go the the website and download it. First, i install the firmware, click the update button, (while this happens, backlight goes off) wait till its finished, says updated successfully. Then i install the software.


Ok, so backlight hasnt come back on, media keys dont work. restart computer, still no backlight and media keys. uninstall, reinstall drivers. No luck. I go back to the firmware, to which it now says "Cannot open USB device, please reinstall driver!)


Gone into the driver location, installed the drivers, still no luck. In Device Manager, there is an unknown device, i let it search online for the correct drivers AND manually set it where to search. I have also tried it on a different computer, and it still will not work. Am i doing something stupid or is this keyboard not working within the 10 minutes i have had it??

Link to comment
Share on other sites

Solved - After disconnecting, reconnecting, and numerous times reinstalling, it was indeed the firmware and the program that bugged... but it finally decided to recognise the device and now works....


doesnt bode well for the rest of the software...

Link to comment
Share on other sites

  • 4 weeks later...

This problem actually happened to me before. After a firmware reflash, my keyboard backlight also

stopped working and the media keys were not functioning. :eek:

I was really afraid I had to send in my keyboard until I was able to stumble upon this fix.


I notice that whenever I plugged in my keyboard, windows would reinstall keyboard drivers and whenever it was finished,

I would see on the bottom right corner of my screen "USB input device installed."

The corsair firmware utility would never recognize my keyboard whenever my keyboard was installed as only an

"input device" and I would get an error message "cannot open usb device, please reinstall driver."

After replugging in my keyboard like around 20 times, my keyboard was finally recognized and installed by windows as a "corsair keyboard."

Miraculously, the firmware update was also able to work its magic on my keyboard and I was able to regain my backlight and media keys.


I hope this post helps out other people with similar problems on this forum.

I don't know if this keyboard has problems that has to be fixed through its hardware or whether the firmware update was simply buggy,

but this problem can be fixed without a RMA if you guys just take the time to test out all your ports.:D:


p.s. my computer has like 15 usb slots so I just plugged the keyboard into each port until it was finally recognized.

Link to comment
Share on other sites

I think this is more of an issue with Windows 7.

The USB drivers sometimes don't load up for whatever reason.

I had a phone which stuffed up during an update because the USB driver wouldn't initiate itself or something (code 10). Plugging the usb cable into a different USB port worked eventually.

Link to comment
Share on other sites

  • 3 weeks later...

Soo.. my corsair k90 mechanical keyboard was working perfectly upon plugging it in and being recognized (or so I thought until I restarted my computer, this caused a hang in the bios over and over.. figured it out pretty quick though)


initially the volume worked as well as all of the normal keys and lights. I went to go grab the software and install it and the firmware. I installed the software first (not sure why.. this seems backwards) then the firmware. It seemed strange that the firmware may not have been fully completed but I impatiently pushed exit thinking that it was.


Lights were not working. Typing was repeating characters about 13 times ever 3rd punch. No media key functionality.


After punching into Google for an answer I figured I should just try re-installing the firmware after reading this thread .. this time I waited much longer and the little firmware box said it was complete then I exited. I must note that the first attempt to re-install the firmware failed. I did NOT re-plug my keyboard like others.. I just simply ran the software again and it worked.


This fixed all of my issues.


Good luck! Great keyboard. Minor hitch.

Link to comment
Share on other sites

  • 1 year later...
  • 7 months later...



Forum won't let me start a new thread but this is exactly the same issue im having.

I've recieved a Raptor K50 for a birthday present, brand new sealed in box. plugged in and followed the instructions supplied with the product to download the correct files, the only lights i have comming on are capslock numlock and what looks like a small vertical arrow pointing at a small horizontal line. I've uninstalled and reinstalled the software sevral times but every time i try and update the firmware i get the message "Cannot open USB device, please plug the device into a USB port or reinstall driver!"


This is the 3rd corsair product ive had, and the 3rd that didnt work from the box as advertised.


If anyone has a fix please do let me know.



Link to comment
Share on other sites

I'm afraid im not learned enough to know what the Latest BIOS and chipset drivers are. Also i don't have access to another computer to be able to try it on.

i have a Dell System XPS L702X


Processor Information:

Vendor: GenuineIntel

CPU Family: 0x6

CPU Model: 0x2a

CPU Stepping: 0x7

CPU Type: 0x0

Speed: 2199 Mhz

8 logical processors

4 physical processors

HyperThreading: Supported

FCMOV: Supported

SSE2: Supported

SSE3: Supported

SSSE3: Supported

SSE4a: Unsupported

SSE41: Supported

SSE42: Supported


This is information gathered by Steam about my system, i dont know if it helps.


I believe that this laptop is USB 2.0 & can deliver 500Ma.


Thanks again for all the help.



Link to comment
Share on other sites

I have exactly the same problem with my k50. Got it yesterday and spent nearly 3 hours trying to install the software and the firmware over and over. It seams that this is a recurring problem. I don’t care if its windows fault or corsairs, it's there product so they have to find a solution for this. I’m really pissed of because I waited like 2 weeks for the keyboard. It fulfills all my needs. Or rather it would if it worked.

Pleas if someone has any other suggestion let me know.

Link to comment
Share on other sites

Thank you Toasted for the effort & trying so hard to help.

I've since been in contact with corsair's customer support & Tech. suppport.

Both of these entities agree that the unit i recieved is faulty, and wanted to replace the unit, which is nice, but not satisfactory, considering the number of people suffering from this problem on this forum alone I don't want a replacement. Since Tech support & Customer support both agree this unit is faulty, (I have typed proof in the form of my Tech issue ticket) i will be returning the product to the place of purchase in order to get a different brand, this being the 3rd corsair product I've had with issues similar to this, those being headphones, mice and a pair of £180 speakers..


This is a real shame, i love the idea and concept of Corsair's gaming peripherals, but thanks to being 'hurt' over and over again by out of the box problems such as these my trust, is ultimately broken.


Again Thanks to everyone for the help.


& blaz.ferlic, I hope your issue gets sorted. If not contact Tech support, be polite and they may offer to replace the unit.


That being said, Corsair seems to have some very good customer service, but that only reinforces the idea that maybe they have so many problems with their products like this, they'd have to have good customer service..

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...