Jump to content
Corsair Community

My M60 stopped working :(


razr m3

Recommended Posts

Today, I was using the mouse as normal when it started to jolt when I moved it. It didn't move in a fluid motion, it jerked when I would move it. Now the mouse doesn't work at all. The blue LEDs still glow when it's plugged in and the computer detects it, but it doesn't move the cursor and the buttons don't work.

 

I've tried:

 

Un-installing the Corsair drivers, rebooting, and re-installing

Restoring my computer to a previous backup (thinking I may have screwed up a setting or something)

Restoring the defaults on Corsair's mouse software

Using it on a different computer

Using a different USB port

Using another device in the USB port

 

All with no luck.

Link to comment
Share on other sites

Use the link on the left side of the page to Request an RMA. In the narrative portion of the RMA, please state that Yellowbeard wants your mouse for Failure Analysis (FA-RMA). We'll get you fixed up ASAP.

 

Will do, thank you for your assistance :).

Link to comment
Share on other sites

I just got this mouse yesterday afternoon and have had a very similar issue, although now no system I try it on will recognise it. I've tried it in my PC in 5 or 6 different USB ports, 3 of them in the motherboard, my brothers old XP laptop and my Lenovo work laptop. The LED's light up but the DPI profile lights never light up.

 

It did initially work, recognised fine, installed the driver fine and then I quickly got the jerky mouse movements like the OP, setting the polling rate to 2ms fixed the jerky movements and then I put it back to 1ms. Everything was fine for a couple hours, worked great in game, but then I went back to set my macro's. I overwrote all the buttons except left, right and middle click, I even overwrote the DPI switches and then saved the profile to the mouse. Shortly afterwards my PC unrecognised the mouse (while it was still plugged directly into the motherboard) and the DPI profile lights switched off. The driver was still running and I tried deleting the profile I made and reset it to defaults, no luck, the driver wasn't really responding very well either.

 

I restarted and nothing changed. I tried uninstalling the driver but that seemed to completely slow my whole system down and it was running pretty heavy for a while, I tried uninstalling it a few times but noticed I ended up running the same processes 4 times.

 

It was pretty late, so I restarted again, let the system finish it's start up programs and then ran the uninstaller, the system seemed to be running pretty hard every time I ran the uninstaller. I went to bed and found the wizard had finally popped up when I woke up and I finished the uninstall. I didn't have time to try and reinstall the driver on my PC, but I brought the mouse to work and plugged it into my lenovo work laptop, it's not recognising it and I can't install the driver here because it won't recognise.

 

I noticed this thread as well regarding the mouse and the Asus bios.

http://forum.corsair.com/v3/showthread.php?t=102667

 

I gather my motherboard falls into this category, is my motherboard impacting with the mouse? If so, shouldn't it at least work on other systems, or has it maybe fried the mouse?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...