Jump to content
Corsair Community

HS1 - White Noise Problem


humair6

Recommended Posts

Hello, just recently I purchased an HS1 USB Gaming Headset.

Everything seems to be working fine except there is a white noise coming through the mic.

 

I've tried the headset on a different computer, it seems to work fine there. I'm very confident everything on my system is fine (sound card, etc.) I was using a USB mic before this one without any issues.

 

I've tried the various other different USB ports. I have tried uninstalling, re-installing the 1.1 driver. I've tried it without the drive all together. I've tried enabling "low frequency protection/loudness equalization" and doesn't make much difference, except making the over all sound input from the mic louder. The white noise still remains.

 

Looking through the history, I see various different posts describing this problem, one such post is: http://forum.corsair.com/v3/showthread.php?t=91999

 

The problem is nearly identical in everyway (even the screenshot). But there is no solution posted.

 

My store does not accept refunds/exchanges for headset due to hygene purposes, so I'm stuck with this 100$+ headset that's not broken but fails to work.

 

Please help me figure this out, I don't know what else to do. Thanks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...