Jump to content
Corsair Community

Just another one with HS1 problems


scarystuff

Recommended Posts

So I bought a Corsair HS1 headset about a month ago. The first thing I noticed was the electric hum sound all the time, which got worse every time an application opened up a sound channel to the headset (even when nothing was playing). I tried to ignore it but got very tired if I used the headset for more than a couple of hours.

Later the headset developed a rattle sound in left cup when any bass sound was played (like explosions in BF3). Then the headset lost a lot of dynamic and the sound was really terrible now. I have just made a RMA to the shop that I bought them at, hoping to get a replacement headset in a couple of days, hopefully in better quality. Because that seems to be the problem. Very poor build quality.

Which is a shame, because I really liked the surround sound in them in BF3. Really immersive. Would be nice with a general driver that could be used in all headsets, so I could get that nice surround sound in a better quality headset.

 

A few days before the headset went belly up, I tried the newest drivers for them and the electric hum was diminised a bit, but still noticeable.

 

Is all your HS1 headsets made in china or is there a chance of getting a pair with better quality?

 

What is the difference between the HS1 and the Vengeance 1500?

 

Btw, if the headset was out of warranty, I would have taken it apart and fixing it myself.

Link to comment
Share on other sites

I got my replacement headset today. It also has that annoying electric hum :( I was hoping it was just my old headset that had a defect, but it seems to be a general problem. The headset is completely silent when I boot my computer and it's not until the computer sends a signal to the USB ports that the hum begins. This is the only USB headset I have tried, so now I'm wondering if it's all USB headsets that have this problem or just the Corsair ones?

 

I do have some small desktop speakers that use USB, but they are completely silent, so I'm guessing it's either a hardware or software problem with Corsair HS1.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...