Jump to content
Corsair Community

TWIN2X4096-64005C, only one stick works, one doesn't, 4 packs


Recommended Posts

I have a GA-MA785GM-US2H board running Corsair XMS2 2 x 1gb which runs perfectly, no overclocking etc.


I recently purchased a pack of TWIN2X4096-64005C. One stick worked, the other stick didn't. I tested in all combinations, proving all ram slots worked and and in all combinations the same stick failed to allow the system to boot. I contacted Corsair support who RMA'd the TWIN2X4096-64005C. The returned new TWIN2X4096-64005C arrived today and I have the same problem. One stick works perfectly, in any slot, with any existing ram in any slot but one stick is DOA. On powering up with the 'problem' ram stuck the PC doesn't even get to bios.


I have a colleague at work, they bought the same memory upgrading as me from XMS2 2 x 1gb to 2 x 2gb. Same experience, 1 stick works, 1 stick doesn't, appearing to be dead.


This seems very peculiar, always used Corsair memory before and never had a problem.


Can Corsair advise ? This appears to be a bad batch given 4 sticks do work and 4 sticks don't over 4 twin packs.


To confirm bios updated, reset to default values, all memory slots proved to be working, 1 stick failed to work on multiple machines out of 4 packs.

Link to comment
Share on other sites

1st batch from me was 2423503 which are with you now.


I'm going to try and get a refund to be honest rather than RMA a 2nd lot. My colleague bought his via Amazon so just got a replacement direct from them and now a refund.


If the RMA number brings something up please let me know!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...