Jump to content
Corsair Community

H100 and PC Sleep


Recommended Posts

Strangely, when I sleep my PC (Win7 x64) the system sleeps, power light starts flashing, but instead of stopping or slowing down, the H100 seems to get rather excited and speeds the fans up to maximum. This is ... kind of annoying, since I'd expect my PC to be almost silent when asleep - otherwise, what's the point, really?

Any thoughts? How is the H100 controller supposed to know that Windows is sleeping? Why would it speed up the fans? (The H100 is controlling both fans on the radiator directly).

thanks for any advice!


Link to comment
Share on other sites

I think I know what the issue is, and I doubt highly it is the H100's problem. It sounds like your PC is not in S3 sleep, but in S1 sleep mode. Are only the H100's fans running?


In S3 sleep mode, all power is removed from the PC, except the 5V standby power to keep the RAM memory on, to store the PCs state when sleep was activated. The H100 only uses 12V power, which is off during S3 sleep. Many PC components don't know they are going into sleep mode, that is controlled by Windows, and components go to "sleep" by having their power removed. In S1 sleep the CPU is still on but not executing instructions, and other PC components will still receive power. The H100's reaction to S1 sleep is something I am not familiar with, but it's behavior is not surprising given S1 sleep's behavior.


Anyway, you need to get into your UEFI/BIOS, and find the Sleep state setting, which is probably set to Auto or S1 now. It should be set to S3, which ought to fix your issue. Hopefully your problem is not a X79 platform issue, or some issue with the UEFI/BIOS.

Link to comment
Share on other sites

Thanks for your detailed info - it allowed me to fix the problem! I wasn't assuming the H100 was at fault, just trying to understand how it should know to shut down.

This UEFI BIOS doesn't directly support a sleep state setting, but it does allow S3.

(powercfg -a shows available states, S1 & S3 allowed).

Turns out the problem was I'd disabled hibernate in Win7 (to save space on my SSD - I don't really need hibernate so much as I have a UPS) - anyway with hibernate disabled, Win7 wasn't sleeping to S3 state, only S1.

Re-enabling hibernate fixed the issue. Sleeps fully now, with the H100 totally shut down.


Link to comment
Share on other sites

Glad that worked for you, although I've had some new ideas about your situation.


It seems odd to me that Hibernation would need to be enabled for S3 sleep to function. I have Hibernation disabled on all my desktop PCs, and S3 sleep works fine (except for my P67 board, S3 sleep is flaky, the PC has insomnia at times, or narcolepsy.) I keep seeing useful options such as Suspend Mode, that is available on an ASUS X58 board, unavailable on newer boards. That allows you to choose S1 or S3 Sleep.


First, are you sure you are entering S3 sleep, or really Hibernating? I'd think you could tell by how quick the resume is, but with a SSD it might be almost as fast as coming out of S3.


Next, you could try enabling C1E if it isn't enabled, which might allow S3 Sleep without Hibernate enabled.


Finally, this issue might be a X79/2011 thing, or your board or UEFI is behind this problem. Not that you board is broken, but a quirk of the board, most boards have at least one IMO. :sigh!:


I am wondering why the H100's fan controller firmware seems to shutdown when the PC is in S1 Sleep. Power to the H100 via the molex connector is unchanged in S1 Sleep. The only possible communication with it would be via the pump speed wire connected to the CPU Fan header. I'm guessing the signaling IC in the fan controller detects a difference in the resistance/impedance in the CPU Fan header connection, and then the firmware shuts down for some reason. Curious... :thinking:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...