Jump to content
Corsair Community

Statement from Corsair appreciated - Link speed on Mac's only 1.5 GB/s


Recommended Posts

Dear people from Corsair,


meanwhile I found numerous threads in this forum reporting Mac users only get a 1.5 GB/s link speed in combination with Corsair Force 3 SSD's. Even if their hardware is capable to handle SATA II speed. To be fair this issue also appears on SSDs from other vendors.


It would be great to get a statement from Corsair how you are dealing with this known issue:

- we do nothing, the issue is caused by someone else

- the issue is under investigation, we are working on it

- we don't recommend to use Corsair in combination with a Mac

- or...


It would be great to get more information on this issue from you,




Link to comment
Share on other sites

Yes EFI 1.7 should have fixed it. And there are some SSDs in the market which work at link speed of 3 GB/s in combination with MacBooks (2008-2010).


A very few people are reporting that it is working if they turn their computer on and off. But these are exceptions.


As older (2008-2010) MacBooks are able to connect with SATA II speed with the newest firmware installed it should not be too difficult to fix this issue.


As Corsair is ignoring this problem (they never answer threads already reporting the issue) - it seems they have no interest to find a solution for it.

Link to comment
Share on other sites

The Update from Apple is already installed.


It is at Corsair to fix this issue. There are SSD Products in the market which don't have this issue in combination with Mac's. I'm sorry it is not allowed to name competitors in this forum, as this is a Corsair support forum.


It's a little bit disappointing that no one at Corsair is answering on this issue.

Link to comment
Share on other sites

Sorry, I have to return my Corsair SSD now.


If you want to avoid further frustrations please remove the label "Compatible with OS X" in your product descriptions:

- You don't support this platform

- You don't offer firmware upgrade tools on OS X

- Your Force 3 SSDs are not working with SATA II link speed

Link to comment
Share on other sites

Are you guys sure its a Corsair problem or quick to judge? After reading everything on Apples forums and Corsair's, Apple acknowledge they have an issue on their end.



Test the Corsair SSD in a non Mac system or a possible newer year (2011) and see if the issue still happens. I also know 2011 Macbook Pro has issues running SATA III performance and only getting SATA II #'s. People were quick to judge SSD manufactures when it ended up being the actual SATA cable built in the Macbook Pro that had issues.





Let me know what you guys think as I'm simply trying to understand the issue and help whoever I can out (I currently do not own a Macbook Pro but looking into buying one).

Link to comment
Share on other sites

No I'am not judging quick.


Your links are referring to problems with SATA III speed. I'am asking only for SATA II speed instead of SATA I.


Your last link is referring to a company who is offering SSD drives which work with SATA II speed on MacBooks (2008-2010). Yes, this company offers support for Mac and also offers Firmware Update Tools for Mac.


What I realized is that Corsair is focussing on Windows. That's fine for me, but they shouldn't add "Mac compatible" in their specifications.


There is a lot of excellent feedback in the market for Corsair SSD's running on Windows 7. But Mac Users should know the risk if they are going with Corsair.

Link to comment
Share on other sites

Take a look at the link below on Apple's Website:



I think the risk is not purchasing a Corsair SSD, but purchasing a Macbook Pro. Buying the MacBook Pro as is, is awesome, but the second you try any upgrades to it seems that many customers start to run into issues. Based on your Spec it shows you're using a Nvidia Chipset, which could be the root of the issue. If the Force 3 works in other platforms at SATA II and Apple advertise SATA II performances I would have to assume that the issue would not be with the SSD, but with the platform you are trying to use it with.



For now I think I will pass on purchasing an Apple system because its having issues with just more than one brand of SSD's, possibly meaning its not the firmware on the SSD. =)



Link to comment
Share on other sites

@ Axel7


are you still having problems ? i just Quick Benched my MacBook5,1 and it it is SATA 3GB negotiated link speed. i think what you need to do is get Quick Bench 4.0 and post some screen shots.


here is my '11 Mac mini Server i benched last night with two FORCE 3 SSD in a striped array ;) - both SSD worked right out of the box !




i have a 3rd FORCE 3 120GB i'll install in my 5,1 tonight and bench it - just so that we are apples to apples.


attached are SS of my rig with a corsair CMFSSD-128GBG2D installed:






Link to comment
Share on other sites

  • 2 weeks later...


thank you very much for helping me. After getting no feedback from Corsair I decided to choose a product from a competitor. This products fits better to Macs. Negotiated Link Speed was 3 Gb/s and they are also offering firmware update tools for OS X.


Corsair have perfect well priced products for Windows. As long as they are offering no support for Mac and tools it is not always the best option for Mac users.

Link to comment
Share on other sites

  • 3 months later...

Mac mini 2011 core i5.

speed test result is only 2 times faster than my bloody slow 5400rpm Hard disk.

about 120MB/s.


I have been working on it all day and I've found the problem is this FXXin SSD.

This is not compatible with Mac guys don't buy if you using Mac

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...