Jump to content
Corsair Community

F120 dead - Please help!!!


wellysm

Recommended Posts

Hi, I had this SSD for less than a year and used it on my personal computer with barely any data on there... however the data that was on there was the most important docs..etc I have

 

tonight my computer froze on the screen and restarted... after the restart it just froze on the gateway screen. after much fooling around and diagnostics, the only way i was able to get into the Bios or Boot menu was to remove the SSD (i tried ram, other hard drive...etc)

 

 

I tried everything i can with the SSD, including putting it into an external encloser... still no luck

 

The only hope I got that once the computer recognized the drive and started installing, however failed with error "drive unplugged"

 

 

can somebody please tell me what I can do to get it to work.... or is it a hopeless solution...

 

This is practically the most expensive hard drive i bought, yet the only one that died on me like that and i am very disappointed

 

 

thanks!!!

 

 

Gateway P-7805u FX

Windows 7 - 64 bit

Intel Core 2 Duo Processor P8400 (2.26GHz, 3MB L2, 1066MHz FSB)

17" WXGA+ Glossy LCD display at 1440x900 (Reviewed with a 1920x1200 WUXGA Panel)

NVIDIA GeForce 9800M GTS with 1GB GDDR3 memory

Intel 5100AGN Wireless

4GB PC3-8500 DDR3 SDRAM (2GB x 2)

500GB Western Digital Scorpio Black hard disk drive (7200RPM) + F120 SSD (primary while the 500 gb was just storage)

 

DVD SuperMulti (+/-R double layer) drive with Labelflash

Link to comment
Share on other sites

Hi,

 

Thank you for the respond Yellowbeard and Toasted.

 

I have tried the SSD in dif computers - when you put it in it would freeze the computer on the splash screen where you have the option of going into the bios or choose boot (F2 and F10). However pressing either one does nothing.

 

In an HDD enclouser, after plugging it in and out several times, the odd time it would detect it for a second and go to start installing it then say error drive has been unplugged

 

in regards to the RMA - I just realized that there is no warranty on it as the policy for refurbished is apparently only 30 days.

Link to comment
Share on other sites

  • 2 weeks later...

Yes, I've tried that

tried different computers

different enclosures

Directly inserted into laptop (which made everything freeze even Bios)

Did that again after I reformatted laptop with windows on another drive... laptop would boot up fine with the normal drive...when the SSD is inserted into the 2nd empty slot as an extra drive, it would freeze up the whole thing (aswell as the BIOS)

 

 

I looked into data recovery services and they are all well above 2000$!!!

 

I paid a premium for a brand that didn't last 6 months, and now I am stuck with paperweight that had important information and files on it which may never be recovered!!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...