Jump to content
Corsair Community

Hx650w


DarkAlchemist

Recommended Posts

This morning the power supply, a replacement for another Corsair PSU that up and died on me, started to make a fan noise as if the bearings are going out. From a soft whisper to a sound reminiscent of bearings that need oil (not something I hear from computer fans). The unit is spotless with not a spec of dust to be seen so I think the bearings in it (reason I only buy Sony wave bearing fans for my PC) are dieing.

 

What do I do with this?

 

Thank you.

Link to comment
Share on other sites

I think I may have posted this in the wrong section since Ram Guy hasn't responded as to what to do with this thing (already removed from the pc) and I see he posted this morning over in the warranty section.

 

I hope this is the right place but I might post over there as well.

 

Nope, right place, he makes his rounds.:) If it is already a replacement contact CS by phone with your previous RMA number and they should cover shipping both ways.

Link to comment
Share on other sites

You will have to call CS by phone. There is no access to CS from the forums. Just call with your RMA number and explain it to them. I'm sure they will take care of you.

I called them and they are sending me a return label and a new RMA. They said they would even cross ship once the package is in the shippers hands (I guess so they can track and see I am not stealing anything and really did ship it back) and to call them back after I drop it off.

 

So far so good.

Link to comment
Share on other sites

I sent it back to them yesterday then went home to call Corsair and they sent a replacement out to me immediately, BUT what I do not get is the model they sent to me is the HX620 (my original model) yet I sent them back the HX650. Ramguy said the HX620 was obsolete when I returned it back in May of 2010 and why I received the HX650 in its place so I am confused and will call Corsair on Friday to see what is up.
Link to comment
Share on other sites

I was busy today so I couldn't call but I did send an email with my RMA number as the title of the message but no word.

 

So, how could it be an HX620w, when I sent them the HX650w (the one you sent to me in June 2010 as a replacement for my old faulty HX620w), because it was made obsolete over 18 months ago?

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...