Jump to content
Corsair Community

Please help: F120 SSD, constant 0xf4 BSOD - possible to fix or clone?


bluel

Recommended Posts

Hi,

 

I've had my Corsair F120 SSD for about 8 months now and I was in love with it. I never had any problems at all until the end of November when I suddenly started getting BSOD 0xF4 codes, as has been mentioned everywhere here in the forums (yes, I have been reading). Unlike some others, these BSOD happen every single startup within 1-5 minutes of Windows loading.

 

I have updated my BIOS, but am afraid to update the SSD firmware, and frankly am not sure I even could because I get a BSOD before I can download the zip file or copy it from anywhere else. I'd certainly get a BSOD in the middle of the firmware update. This also means I only have time to copy a few files at a time from the drive to another. I've attached a number of minidump files here.

 

I've tried cloning it to another drive, but none of the cloning software can read the drive successfully. In ubuntu live, fdisk either generates a long list of read errors or just fails totally trying to read the ssd.

 

When I attach the ssd to another OS, I can open it briefly but then the same problem, minus the BSOD, happens. I can open the drive, read it but very quickly the explorer window will freeze and then the SSD disappears totally from windows until I restart.

 

My questions:

1. Is there anything I could possibly do to save this drive?

2. Is there anything that might clone the drive?

3. Is it possible to update the firmware safely & would it even help me?

 

Many thanks

 

Of course I can reinstall everything on a fresh drive (already started doing that) but I had done so many things to get Win7 to work with the SSD/TB HDD configuration that I'd much prefer just cloning or saving the drive if at all possible.

Link to comment
Share on other sites

Also, what would dd actually do if I tried to clone the drive? If the problem is bad blocks, would dd just ignore them or leave empty blocks in the image?

 

Or is there another way to get an image of the failing SSD?

Link to comment
Share on other sites

If you use 'dd if=blabla of=blabla conv=noerror,sync' it ignores unreadable blocks and writes zeroes in their stead. In my case it didn't help since the drive always disappeared when I tried to read some (broken) blocks, and I couldn't find a way to avoid them:

 

http://forum.corsair.com/v3/showthread.php?t=101309

 

That's what I suspected would happen as well. Fortunately, I discovered that I had in fact been including the image in my regular backups, so I was able to restore my OS intact on a new drive. I'm still stuck with the broken F120, however.

 

I attempted several things last night:

* Swapped SATA ports, swapped SATA cables

* Turned on hotswap for sata port

* Enabled AHCI

* Attempted to install the Intel RST enterprise drivers, but was unable to, the setup said the system did not match, and it would BSOD too soon anyway

* Wanted to attempt the LPM registry tweak, but could not because of the above

 

I just remembered this morning that I need to check the serial number for an RMA - seems that's my only real option I guess.

Link to comment
Share on other sites

Ok, so since the drive cannot be recovered in any apparent way, I tried doing a SecureErase in order to RMA the drive, however, even this will not work. In the PartedMagic OS, I cannot access the SSD, only getting SMART errors and the drive is detected as "unknown model" and unopenable, unerasable.

 

Now what am I supposed to do? I don't want to send back a drive with all my data still (briefly at a time) accessible. Am I just out of luck and will have to take a full loss on this drive?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...