Jump to content
Corsair Community

Help Previousy working16GB Flas Voyager now says need to format


mstar

Recommended Posts

Does anyone know what is going on here. My Flash Voyager drive, with all my precious travel photos from the summer, now tells my notebook and PC that to use it I have to format it. How do I fix this?

 

"You need to format the disk in drive F before you can use it"

 

I am using Win 7 64 bit on both machines. It worked fine last night. This morning I get that message.

 

Any help is appreciated. I need to recover the data on it at the least.

Link to comment
Share on other sites

I used this free program http://www.cgsecurity.org/wiki/TestDisk

The test disk program worked but not for all files. while most photos restored in their original files, some PDFs were not restored, some were mixed up or not restored properly even if the thumb nail was.

 

Their Photo Recov progam worked better restoring I think all files even though they are not in their folders and mixed up. But it seemed to restore all the files. It seems with Photo Recov program does not give the choice to restore only undeleted an files. So more gets restored than you intended but that is a good thing.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...