Jump to content
Corsair Community

My experiences with F60 Firmware 2.4


Recommended Posts

I thought my story with firmware v2.4 might be useful to other Sandforce SSD owners, so here we go ...


I'm running an old Q6700 Core 2 rig with a P45 chipset and ICH10 southbridge (it's not that much slower than Sandy Bridge, runs everything I need fine, so why upgrade?) and Windows 7 x64. Last week the computer starting hanging five minutes after booting, and it didn't take much investigation to find that it was the Corsair Force F60 SSD which was locking up.


I tried copying off all the data by dd-ing the whole disk from Linux, but the SSD kept hanging anytime I went past 16Gb into the SSD. Really, really unhelpful. So I copied off the most important stuff in each 5 minute window from boot. Better than nothing I suppose.


Now, since I first got this SSD performance was not great, even with firmware v2.0 which I installed just after buying it. The old Q6700 doesn't have much memory bandwidth compared to the newer architectures, so I took it for granted that it wouldn't be much faster in sustained reads and writes than a HD. The super low access times are the main benefit, but I was typically seeing 140Mb/sec reads and 70Mb/sec writes, that sort of region. I never had the problem of the vanishing SSD on boot, but resuming from standby only worked 50/50. Resuming from hibernate did work okay, and I can live with that.


Once I accepted that my OS installation was hosed, I thought I ought to factory reset the drive (secure erase) and try a few tests. I dd-ed random data into the whole drive from linux, then read it back and md5sum-ed it. I then dd-ed zeros into the whole drive, and again used md5sum to verify it had written correctly. I alternated each three times, and each time the md5sums were correct and more importantly the drive was no longer hanging itself five minutes after boot.


Satisfied that the drive probably was working, and that it was simply a firmware bug, I did another factory reset and installed firmware 2.4, then installed Windows 7 x64 plus all service packs and updates. Thinking that it felt subjectively quicker than before (often this happens with any new Windows install anyway), I ran CrystalDiskMark and you can see the results attached. One is for random data, the other is for zeros.


You will note that my subjective feelings were not incorrect. These benchmarks are about double for writes than they were before. Reads are significantly better too, and for where it is reading and writing zeros both the sequential and 512Kb blocks are maxed out right against the SATA II bandwidth wall, even on this old system with its PC6400 DDR2 RAM. In short, I am impressed with this firmware update - or perhaps the drive had some data corruption in its tables from the beginning, or perhaps there was some other reason why performance was originally not fast.


Unfortunately, this drive still doesn't resume reliably from S3 sleep even with firmware 2.4. I personally don't get why Sandforce or whoever don't just allocate an engineer to the problem with any bog standard Intel motherboard and CPU because this is a very repeatable bug. I guess it doesn't satisfy their cost benefit analysis. Anyway, if your Sandforce SSD (or indeed any SSD) goes belly up, you might find the above useful for deciding whether to factory reset the drive and keep using it.


I do have to say though that I will never buy a SSD that hasn't been on the market for at least a year ever again. And I want to see near zero defects - my SSD problems are clearly a failure to correctly handle data corruption in the firmware. Probably some sort of garbage collecting routine started up about five minutes after boot, encountered the data corruption and hanged the ARM processor in the SSD. It should NEVER be possible to hang a processor in embedded firmware, at least if the design is done right it ought to at least self-reset and indicate a SMART error or something. Bad quality programming in the firmware in my opinion. For that reason alone, I personally will never touch Sandforce ever again.


Best of luck,




Link to comment
Share on other sites

  • 1 month later...

Thanks for sharing...


Same(ish) thing just happened here.


Used to have some crashes but always blamed something else.

(GPU, PSU... was also afraid at first it was due to overheating but pretty quickly ruled that out)

Not once did I suspect the F60 (purchased december '10 - 2.0 firmware)

But now over one year later it would not boot up again.


After trying "everything" to get it to boot again I started googling the SSD.

Found many similar problems with Sandforce drives.


Eventually managed to backup all essential files with a Linux Live CD.

(Only thing that would detect the SSD. Tried many "recovery disks" + old XP installation)


Currently just using Ubuntu Live from a USB and suspending it instead of shutting down. (So that i don't have to recover bookmarks and edit keyboard layout every day)


Guess it's time to return this thing :'(


- Asus P5E-VM HDMI (latest bios)

- Core 2 Duo 6300

- Windows 7 64bit

Link to comment
Share on other sites

  • 1 month later...


This topic is now archived and is closed to further replies.

  • Create New...