Jump to content
Corsair Community

SSD GT 120 and Asus P8Z68-V PRO/GEN3 not able to see the disk in the flash utility


Recommended Posts

So... I write this post after what I did to hopefully point some ppl in the right direction and also give corsair the info to fix things.


What happen was this. First I used my SSD Force GT 120GB in a old computer. Right after I buyed it I downloaded the flash utility and firmware 1.3. As it turned out it already had the "correct" FW. Well at least I saw the drive in the firmware utility.


Then I bought a new computer with a Asus P8Z68-V PRO/GEN3 motherboard, i5 2500K and so on... I think you can see my spec if you press a button by my username.


It all "worked" and I had connected my SSD via the navy blue (I think marvel) controllers on my Asus P8Z68-V PRO/GEN3. Things seemed to work and Im not totally sure how long it lasted before I had my first problem but since I bought the parts in the begining of nov 2011 it can't be long.


It was kinda nice in my new EFI Bios I could see the SSD, CDROM, my printer (think its because its build in cardreader in it) and also my external USB HDD as boot devices I could drag and drop in what order I wanted them to boot.


Then one evening I was watching some series using VLT Player v1.1.11 and I pressed pause since I needed a pee brake. I took a pee and washed my hands and when I got back the computer screen was black with a cursor blinking. I was gone like 2-3 mins. I thought "what the heck now, is it in some kind of standby already?". It turned out that the computer had restarted itself (crashed).


I tried to restart my computer but it ended up on the black screen with the cursor blinking. It turned out it tried to boot from my external USB drive. I went into my EFI Bios... no SSD drive there, earlier I saw the drive with the other boot options but now it was gone. I dont think I could see it at all until I actually turned off the computer and on again... but then I didnt found it where it was before. In the list where I could drag and drop it I never found it again, but on the right side of that list there is also F8 (Boot options) and in that list I could find it, strange. Anyway I clicked on it and windows loaded as normal and started correctly (puh!). So I restarted the computer and went to BIOS again and made a "load optimal defaults". I still couldnt see the drive where I "should" be but it still was in that other boot list. After I did this the computer always loaded from the SSD as it should and I couldnt be bothered with it at this moment.


I have to note here for the readers... Im 35 years old and started with computer when I was 8 so Im pretty experienced. BUT!!! Im starting to be pretty bored with the whole "fix PCs", VERY bored, its no fun anymore as it was before. Now I pretty much consider myself to be able to fix my PC no matter what but its really really boring and just gets me upset very fast so I just want easy mode and therefore I couldnt be bothered by checking exactly what was wrong since it seemed to work.


Anyway, computer worked but in the following days I had another 3-4 crashes, that would be total 4-5 in total with the first crash, maybe more, Im not sure exactly how many. In at least 1 of those other crashes I had to turn off my computer and load optimized settings in bios to get it to work as I wanted again. I may have needed to do this more then one time again but at least one more I did it because I had to and the others I did "just because I might aswell".


The thing is, out of those 4-5 crashes 2 happened EXACTLY when I had VLT Player on pause, that's cant be a coinsidence, can it? I love VLT Player so I wont change it just update it when available (not now). What I will do is copy this post and mail it to them.


Yeah, anyway... after a few crashes I decided "Hey why not check corsairs page for some firmware updates". I found 1.3.3 and I downloaded my 120 GT "kit". I launched the FW utility but I couldnt see the drive, hit the "rescan" but no drives. I was fooling around a bit and tried to apply the AHCI thingy. I did this but I could see it should be already on that... anyway... I never got to see the drive in that utility at that time.


Then yesterday I've had it and started reading even more posts here on the forum and someone mentioned something about a ASUS or ASrock MB and I decided that I should try to change my SSD from being connected to the navy blue SATA controlers to the "grey" ones, both are SATA 3 controlers, but I think the navy blue are marvel controlers. Said and done but before I did this I also made a benchmark test in HD Tune Pro 5. Im attaching the pics of my benchmark. Then I changed to the grey controler and in Windows I could find the SSD in the flash utility (still used the same file so I didnt have the wrong ones earlier). I also uninstalled "Intel rapid storage technology drivers since I wasnt gonna use my SSD as cache for my other driver, I think that's why you use them, pls correct me if Im wrong. Im not sure if I uninstalled those before or after the FW update. After restarting Windows it made an update (found new hardware I think it said) I had to restart it again and after that I did another benchmark.


You see my 2 files attached. The average speed changed from 181,1 to 251,3 MB/s after what I've done above. Still I think this speed sucks and I hope there can be changes/tweaks/updates to something to improve it. It's suppose to be 550MB/s read top and 515MB/s write. I know that's the top speed but I never got any better then 363,1MB/s, that's only 66% of the theoretical top speed?!?!?!?!


As of now there are no FW for my MB and I have the first MB's of this version coming to Sweden since release so I understand that Asus might have problems on their side too and therefor I will send this post to them aswell, I hope.


And just for your knowledge, I have bought a special SATA 3 cabel for my drive so it should be a better standard on it and workning, should...




Tips and ideas to improve my performance or other stuff is welcome!


Also if you would like to post your benchmark if you have a "Corsair SSD 120GB Force GT Series" or at least one of the sizes of that model, I dont care about the other models, make your own thread ;)



EDIT: ****, I dont know if this was the correct place for the post or if I should have moved it up so it wasn't under SSD Firmware update, pls move it

EDIT2: I've sent a post to Asus

EDIT3: I've posted a post on VLC's homepage



Link to comment
Share on other sites

It is known that Marvell controller sata III (navy blue connector) has some compatibility problems with ssd (even with spinning hhd).

It is better to plug Force 120GT to native controller from Intel chipset (gray connector).

I think your second HD Tune tests are OK because this benchmark test ssd in real life mode (with incompresible data).

I will send you an email with a HD Tune comparison tests with P68 chipset native controller and many brands ssd (including F120GT)


To test maximum speed of your F120GT you need to test it with compresible data. For example ATTO benchmark (friend of ssd vendors).

I have an F120GT (updated to firmware 1.3.3) connected to native Intel controller of Sata III Z68 chipset(Asrock Extreme 3 Gen3) and I have no BSOD or crashes.

Here is my ATTO test.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...