Jump to content
Corsair Community

Flash Voyager USB 3.0 32GB compatibility issues


mannixita

Recommended Posts

I bought a Flash Voyager GTR 16GB and it worked very well, never had any issues. Until someone stolen it...

Now I bought a Flash Voyager USB 3.0 32GB and I'm going crazy: almost no issues with USB 3.0 controllers but the backward compatibility is near zero.

It reminds me the WD Essentials USB 3.0 HDD I bought almost a year ago, but they fixed it later with a firmware upgrade and now works really smooth.

In a dozen of USB 2.0 PC I tried the pendrive and almost all of them can't read it. It's not a power issue, it behaves crazy, often on the same port in different ways: does nothing, start flashing led endlessly, unit installed but unreadable (windows asking to format it), unit installed but without partition.

I have a crappy Toshiba notebook from office which is really pick with USB drives, USB 2.0 controller and there the pendrive is ok.

When I use it with a USB 3.0 controller also it works fine.

Do you plan to release a firmware update soon to fix it?

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...