Jump to content
Corsair Community

Firmware update


pseguin

Recommended Posts

I couldn't get the update tool to recognize any SSD's until I set them to IDE mode in BIOS instead of AHCI. I run as Administrator and it finds the drive and I click to update and select the right file. Well, it's supposed to take 10 seconds, but I see no activity at all and I can walk away for 20 minutes and it's still doing nothing. Eventually, I get a blue screen, the computer reboots and then can't find the SSD. I have to power off and then it finds it. (this is what I was hoping the update would fix) How do I get this thing to update my firmware? in AHCI mode the updater won't see any drives.
Link to comment
Share on other sites

I couldnt see my drive either... something happended and I couldnt see it in the flash utility, even though it was the right one... I have a Asus P8Z68-V PRO/GEN3 motherboard and I could see the drive again after I changed to the "grey" SATA connectors on the motherboard, earlier I used the navy blue ones (marvel I think).

 

Flashed from 1.3 to 1.3.3. I dont know what did what but aftat that changed I could flash and I also made a new benchmark on the drive and it worked alot better.

Link to comment
Share on other sites

so the ideea is to set compatibility mode to windows 7 (try with Vista), i believe the problem is with the windows maybe if you put your ssd on another system and use it not for booting maybe you will see it with the updater... Remember you must run it As An Administrator.. That's how i did it.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...