Jump to content
Corsair Community

BSOD: Kernel Inpage Data Error, and recovering from it


BakCompat

Recommended Posts

I've had a Force GT 120 for approximately 2 months now. It shipped with 1.3 firmware originally.

 

I had a BSOD about 3 weeks in where it was no longer bootable. I thought the boot sector got jacked, and messed with it a lot to try and get it fixed. I finally got it working after trying many things.

 

2 nights ago, I had another BSOD. This time it was a stop error 7A on svr.sys, which is apparently related to Samba. At the time, I was playing League of Legends online, when the game slowed down over the course of a few seconds, started to corrupt video, paused, then BSOD.

 

After rebooting, the SSD was no longer bootable. It would go to a dos screen after the mobo BIOS, giving me the usual "device not bootable" routine. I think this was the same thing that happened the first time, but with a different file in ram at the time. So, it sat for a day that I didn't have the time to work on it, and I came back last night to get it up again. I pulled the second drive off the sata3 port and moved it to a sata2 port. I moved the SSD from sata3 port #1 to #2, being the only thing on the sata3 controller. I rebooted and checked it in bios. After some more jiggering, I got the SSD set up as the first boot device on the sata3 controller.

 

Reboot, and I got it working again, this time without having to run any partitioning/recover/boot sector/win7 repair cd software.

 

After entering windows, it had to "reinstall the driver" since it was on a new sata port, and reboot to save the changes. Now it's working again. But, this didn't solve the inherent issue...

 

So, I decided to flash the firmware. I thought 1.3.2 was current, but checked, and saw that 1.3.3 was now out. I downloaded it and flashed the firmware to the drive. I rebooted. It worked. I rebooted and cleared my CMOS and reprogrammed BIOS. Rebooted, still worked. Thankfully, I did not have to do a secure erase and reinstall of Windows, which would have been the next step.

 

It's operational at the moment, but if this happens again, I think it will be time to RMA the device back to Corsair.

----

Other thoughts: I waited too long to get my $30 MIR on this SSD because I wanted to make sure it was not one of the defective batch which would have required a return back to the Egg. So, imagine my dissatisfaction when I was going to file my MIR a month after purchase to discover it was a 21 day MIR... :/

That struck me as very similar to a certain three letter company that also sells SandForce controller based SSDs and had lawsuits filed on it, and coincidentally no longer has RAM or USB thumbdrives for sale with the Egg, but only SSDs. Hmm, yeah, they're very shady, and that's why I purchased a Corsair Force GT 120 for $215 instead of the three letter company model which was much cheaper.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...