Jump to content
Corsair Community

600T Case fans


Tony64

Recommended Posts

I bought a 600T (White) back in June 2011. Until today the 200mm cooling fans have worked correctly using the circular fan speed controller.

 

Today, I thought the computer was very quiet and saw that there were no lights on the fans and that the fans were not spinning. I moved the control dial and it was not until I got to the maximum setting that the fans started up.

 

At least I have cooling but this is not an Ideal situation. Is there an easy workaround. I don't really want to send the case back for repair.

Thanks

Tony

Link to comment
Share on other sites

Its possible that the fan speed controller has died instead, you can ask for RMA from Corsair.

 

Try just plugging the fan directly on the motherboard to see if it works properly.

 

I think you may be right. I have connected 2 of the fans into the motherboard and they are working. I have left the other fan connected to the controller and that now seems to work at 2 speeds. slow and flat out.

 

I need to sort out a couple of rheostats for the fans connected to the motherboard to reduce the noise. I don't want to send the case back. Too much hassle. It would be nice if they sold the spares.

 

Thanks for your help

Tony

Link to comment
Share on other sites

  • Corsair Employees
It is possible that you have a faulty fan controller. I would try the fan one at the time to the fan controller and see if each fan spins and then try all 3 again. If only one fan spins then there is something wrong with the controller.
Link to comment
Share on other sites

It is possible that you have a faulty fan controller. I would try the fan one at the time to the fan controller and see if each fan spins and then try all 3 again. If only one fan spins then there is something wrong with the controller.

 

Thanks for your assistance. I have tried the fans one at a time. It will run the top and rear fans on their own but the front fan will not run at all.

I have tried it with the top and rear fans and they will not run together.

I have plugged all 3 fans into the motherboard and they all work.

 

I have completed an RMA and am awaiting an email back to see what happens next.

Tony

Link to comment
Share on other sites

I have received my RMA instructions. Corsair want me to send my case to Holland via courier (I live in the UK) at my expense. It would probably be cheaper for me to buy a new case.

If this is the sort of service that Corsair provide, I will have to think twice before buying again.

Tony

Link to comment
Share on other sites

Ohh dear Tony, I'm having some serious issues with the fan controller and audio jacks on my 600t, I do hope they don't suggest I have to send my case to Holland. If this is what happens its crazy.

 

I just got a quote from DPD courier for delivery. They want 117£ plus VAT. If my maths is right, that's £140

 

Over clockers have the case for sale at £112.

 

Hmmm, makes me wonder why I bought a Corsair case, Ram, CPU cooler, and power supply. Am I going to regret these purchases.

 

Jon

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...