Jump to content
Corsair Community

New SSD won't work in AHCI mode


HorizonXP

Recommended Posts

Existing post here: http://forum.corsair.com/v3/showthread.php?t=100387

 

So I just picked up a Corsair Force GT 120 GB drive. After futzing around trying to clone my existing partition, I ended up installing Windows 7 x64 Ultimate fresh.

 

When I installed the drive, I had my system using AHCI mode. It detected the drive with no issues. When I ran Windows 7 installer off the DVD, it had no issues either. I created the partitions on it, and it forced me to put a 100 MB system partition ahead of the single 111 GB partition that I created.

 

It proceeded to copy the files, and I walked away. When I came back, I saw my computer had stopped rebooting on the Serial ATA AHCI screen, where it showed that it had detected 4 devices, but listed none of them. The code in the top right was 23.

 

Removing the SSD's SATA cable allowed the boot process to proceed. I went into the BIOS, disabled AHCI, and it allowed me to use the SSD again, so I could continue the installation. Once Windows 7 had installed, I attempted to switch back to AHCI mode in the BIOS. This caused the same error to occur, with the boot process hung at the same place.

 

Changing cables merely allowed one device (one of my WD HDDs) to show up on the AHCI boot screen, but still, it hung at the same place. It seems that my computer will only boot with the SSD in if I am not using AHCI mode. Note that this isn't quite a Windows 7 issue, because I haven't even reached that part of the boot process. Nevertheless, I have made the relevant edits to my registry.

 

My board is a Gigabyte EP45-UD3L with the latest F9 BIOS. My Corsair drive is running the latest 1.3.3 firmware.

 

I'm at my wits end, so any and all help is appreciated!

Link to comment
Share on other sites

  • Corsair Employees
That is a BIOS or driver issue most likely, to be sure please test the drive on a newer chipset and use parted Magic to secure erase the drive then try the fresh install. You can try and update the Intel chipset drivers then change to AHCI but I have seen the same issue with an X48 chipset MB.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...