Jump to content
Corsair Community

Corsair Force GT 120GB - Questionable for RMA?


Quake

Recommended Posts

Hello to all!

 

I'm having problems with my Corsair Force GT 120GB. I got it before few weeks and just tested as secondary drive for the HW Gurus website (link for review with performance numbers HERE).

 

I wanted to use it as a main drive in my ITX system and this week I finally got all the parts needed to assembly it. The problems starts to appear if I want to boot it from the drive. I can install windows and when I need to restart and continue with installation it won't boot from it. You can watch the video. I tried to HDDErase it, clone the partition with Windows, everything, but no go.

 

Then I thought maybe it is mbo that is having issues. Tried in SATA-III and SATA-II connectors, same problem. I put ADATA S599 256GB from my notebook and everything is ok, put Corsair in the notebook and same problem, won't boot to Windows.

 

Drive has max 20h of working and most of it were while I was troubleshooting for this problem. With HD Tune, there is some error, but Crystal Disk Info says that the drive is ok. I flashed it with the newest firmware (I had 1.3). After update it says firmware: 1.3, not 1.3.3. Is that normal?

 

Here you can see how it looks

http://youtu.be/RSnPvXkKy5s

http://youtu.be/v9X5kTwbje0

http://youtu.be/H7AIY1KaxWg

 

 

I run out of the option, will try on ASUS Maximus IV Gene-Z, but I doubt it will work. So guys, is it for RMA or there is hope for it?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...