Jump to content
Corsair Community

New SSD won't work in AHCI mode


HorizonXP

Recommended Posts

So I just picked up a Corsair Force GT 120 GB drive. After futzing around trying to clone my existing partition, I ended up installing Windows 7 x64 Ultimate fresh.

 

When I installed the drive, I had my system using AHCI mode. It detected the drive with no issues. When I ran Windows 7 installer off the DVD, it had no issues either. I created the partitions on it, and it forced me to put a 100 MB system partition ahead of the single 111 GB partition that I created.

 

It proceeded to copy the files, and I walked away. When I came back, I saw my computer had stopped rebooting on the Serial ATA AHCI screen, where it showed that it had detected 4 devices, but listed none of them. The code in the top right was 23.

 

Removing the SSD's SATA cable allowed the boot process to proceed. I went into the BIOS, disabled AHCI, and it allowed me to use the SSD again, so I could continue the installation. Once Windows 7 had installed, I attempted to switch back to AHCI mode in the BIOS. This caused the same error to occur, with the boot process hung at the same place.

 

Changing cables merely allowed one device (one of my WD HDDs) to show up on the AHCI boot screen, but still, it hung at the same place. It seems that my computer will only boot with the SSD in if I am not using AHCI mode. Note that this isn't quite a Windows 7 issue, because I haven't even reached that part of the boot process. Nevertheless, I have made the relevant edits to my registry.

 

My board is a Gigabyte EP45-UD3L with the latest F9 BIOS. My Corsair drive is running the latest 1.3.3 firmware.

 

I'm at my wits end, so any and all help is appreciated!

Link to comment
Share on other sites

So I just picked up a Corsair Force GT 120 GB drive. After futzing around trying to clone my existing partition, I ended up installing Windows 7 x64 Ultimate fresh.

 

When I installed the drive, I had my system using AHCI mode. It detected the drive with no issues. When I ran Windows 7 installer off the DVD, it had no issues either. I created the partitions on it, and it forced me to put a 100 MB system partition ahead of the single 111 GB partition that I created.

 

It proceeded to copy the files, and I walked away. When I came back, I saw my computer had stopped rebooting on the Serial ATA AHCI screen, where it showed that it had detected 4 devices, but listed none of them. The code in the top right was 23.

 

Removing the SSD's SATA cable allowed the boot process to proceed. I went into the BIOS, disabled AHCI, and it allowed me to use the SSD again, so I could continue the installation. Once Windows 7 had installed, I attempted to switch back to AHCI mode in the BIOS. This caused the same error to occur, with the boot process hung at the same place.

 

Changing cables merely allowed one device (one of my WD HDDs) to show up on the AHCI boot screen, but still, it hung at the same place. It seems that my computer will only boot with the SSD in if I am not using AHCI mode. Note that this isn't quite a Windows 7 issue, because I haven't even reached that part of the boot process. Nevertheless, I have made the relevant edits to my registry.

 

My board is a Gigabyte EP45-UD3L with the latest F9 BIOS. My Corsair drive is running the latest 1.3.3 firmware.

 

I'm at my wits end, so any and all help is appreciated!

 

I get a similar problem with my DELL laptop, but I am able to log into windows 7, but with BSOD and system freezing !.

When i change to ATA not ACHI in the bios, no BSOD no Freezing !!

I sent my first SSD back to Corsair, they sent me a newer model according to the S/N but that has exactly the same problem in ACHI mode !!!!!!!!!!

Link to comment
Share on other sites

So I just picked up a Corsair Force GT 120 GB drive...

 

Removing the SSD's SATA cable allowed the boot process to proceed. I went into the BIOS, disabled AHCI, and it allowed me to use the SSD again, so I could continue the installation. Once Windows 7 had installed, I attempted to switch back to AHCI mode in the BIOS. This caused the same error to occur, with the boot process hung at the same place.

 

Changing cables merely allowed one device (one of my WD HDDs) to show up on the AHCI boot screen, but still, it hung at the same place. It seems that my computer will only boot with the SSD in if I am not using AHCI mode. Note that this isn't quite a Windows 7 issue, because I haven't even reached that part of the boot process. Nevertheless, I have made the relevant edits to my registry. The 100MB system partition is created by Windows in some circumstances, but is not a problem or the reason for your problem.

 

 

My board is a Gigabyte EP45-UD3L with the latest F9 BIOS. My Corsair drive is running the latest 1.3.3 firmware.

 

I'm at my wits end, so any and all help is appreciated!

 

Your description is a bit confusing, but I can see a few mistakes along the way that likely ruined the installation finishing in AHCI mode, that is, with an AHCI driver installed.

 

The first thing to do, when installing Win 7 on a SSD, is that all other drives (except the DVD drive) must be disconnected from the PC. Next, the SSD must be in SATA port 0 (or 1 if that is the first by the boards numbering scheme.) The SATA mode must be set to AHCI before the installation begins, and must not be changed during the installation. Regardless of the reason for changing from AHCI mode, when the installation completes the AHCI driver will not be installed, since you weren't in that mode. If you installed Win 7 in AHCI mode, there is no need to perform any registry edits.

 

With all the stops and starts and mode changes, etc, you did, who knows what state your installation is in. You should start over with a fresh installation after erasing your SSD, and following the tips I wrote. If you still have an issue with the SSD not be detected during the installation reboots, then you'll need to investigate that.

 

I checked your boards web page, the F9 BIOS is the latest, from 01/2010, pre-Windows 7 AFAIK. What is strange is that there are no SATA drivers of any kind available for download. The EP43-UD3L board does have SATA drivers which should work with your board, as they use the same SATA chipset (ICH10.) You can use the standard Windows 7 AHCI driver, msahci, which is loaded automatically when installing in AHCI mode, and is the easiest installation-wise, and then change it later if you like.

Link to comment
Share on other sites

Just so we're clear, you guys do understand that once Windows 7 installation DVD copied files to the partition on the SSD while in AHCI mode, it then rebooted the machine to continue the installation. So up until this point, AHCI mode was enabled and working correctly.

 

When it tried to reboot, the system did not complete the boot process. It halted before it got a chance to load any boot media; I couldn't even get past the screen to boot from the installation DVD again.

 

So we're clear, when in Serial ATA AHCI mode, I'm stuck at this screen:

 

-----

 

Serial ATA AHCI Bios, Version iSRC 1.20E

Copyright © 2003-2008 Intel Corporation_________________________23

** This version supports only HardDisks & CDROM drives **

Please wait. This will take a few seconds.

 

Controller Bus#00, Device #1F, Function #02: 06 Ports, 05 Devices

__

 

------

 

I'm experiencing the same problem described here: http://forums.tweaktown.com/gigabyte/38699-ex58-ud5-sata-ahci-not-working-anymore-wont-even-let-me-format-help.html

 

I think I'm going to have to format this drive and start over, but I'm REALLY hoping I don't have to!

Link to comment
Share on other sites

Who knows exactly why you're stuck on the initialization of the AHCI driver, but that is what is happening, given the screen you posted.

 

You know what the fix in the thread you posted is, but you don't want to do that. You could try doing a repair of your installation from the Windows installation DVD, but whether or not that will correct things, who knows?

Link to comment
Share on other sites

Who knows exactly why you're stuck on the initialization of the AHCI driver, but that is what is happening, given the screen you posted.

 

You know what the fix in the thread you posted is, but you don't want to do that. You could try doing a repair of your installation from the Windows installation DVD, but whether or not that will correct things, who knows?

 

LOL, before you posted your reply, I was already in the middle of formatting and reinstalling. Man, what a pain, but it works! It feels faster than before, I'll do a benchmark in a bit to verify. Thanks for the help. I guess I just wanted confirmation that a format and reinstall was the solution, before I went ahead and did it.

Link to comment
Share on other sites

I'm glad to hear that it's working now. I was going to agree with parsec & to do a fresh install from scratch with ACHI enabled.

 

That's what I started with, but it screwed it up halfway through.

 

So I'll add that AHCI should be enabled, and that all other drives should be disconnected. Only the DVD drive connected, and the SSD is on SATA port 0.

Link to comment
Share on other sites

Yes I agree it's a good idea to remove all other drives. I was having different trouble than you were (I have another post up that I opened), but when I did a fresh install using the Z68 sata ports instead of the Marvell sata ports, I did remove all other drives. I'm hitting about 1GB read and 1GB write now with ATTO on my force 3 120gb raid0.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...