Jump to content
Corsair Community

Issues mounting H80


HeAt_8

Recommended Posts

I finally got my new hardware today and went on mounting it, when i was mounting the backplate i noticed something weird, i cant tighten it enough. I didnt think it should be loose so i found out that i should ask here first before mounting the pump. My issues is that the mounts on the backplate sticks a couple of millimeters over my motherboard and therefore it cant be tightened enough with the screws. So any help would be appreciated.
Link to comment
Share on other sites

It's good you noticed what the problem is, this is not something you've done wrong. We've heard of a few examples of this issue recently, and now yours.

 

Check out this thread where we figured this out. You can use the fix suggested there, or submit a RMA for a new backplate. The thread goes on a bit, but don't give up on it, the fix is in there:

 

http://forum.corsair.com/v3/showthread.php?t=99549

Link to comment
Share on other sites

Just to be sure, if you look really closely at the backplate, you'll see that it must be mounted the right way up.

 

There are two small cut outs in the backplate that fit onto small little "lugs", that if mounted upside down, you get the problem you are seeing which has caught a few people out in the past. Those who have hastily installed the backplate, and not noticed the cut outs / lugs when orienting the backplate run into this issue frequently.

 

If this doesn't apply to you, then please ignore me lol :). Just pointing it out, as it can be easily missed if you don't look closely, and it;s also not mentioned on Corsair's mounting instructions that come with the H80 either.

 

Otherwise, hope you fix your problem soon and your new H80 meets your expectations :).

Link to comment
Share on other sites

I sent an RMA and asked for new washers, jerryrigged it with 1mm washers for now and its as tight as it gets.

 

The good people that deal with RMAs at Corsair usually don't send washers or one screw, most likely they will send all the mounting hardware for your H80. While you may not need all of it, it will be nice to have the extra parts.

 

Once you get your parts, it may not be worth it to swap the backplates. Did you put your washer under the standard one, as suggested in that thread? If so, I would just leave things alone until you remove the pump in the future, and then swap the backplates. The OP of the other thread had the misfortune of receiving a backplate that again had the out of spec backplate nuts. If you do to, then a lot of work for nothing.

 

When you get the new backplate, remove one of the nuts and carefully measure it, it must be 7mm in total length. If it's longer, you'll likely have the same issue.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...