Jump to content
Corsair Community

AX850W switch issue


Xavin

Recommended Posts

Hello. I got my ax850 today and i installed it and fired the system up.

I shut the computer down again to fix the cablemanagement and when i tried to switch the on/off button in the back to off, it goes back to on (I).

I've tried several times to flip the switch to off (0) but it's like when you push down a spring it "shoots" back to it's normal state. In this case (0) being that state.

 

So my question is, rma this unit?

Link to comment
Share on other sites

RMA or return to store for faster service.

RMA link on left ;)

sorry to hear that, if you dont want to wait you can continue to use that PSU, request an RMA and when you get approved call customer service and you can get an advanced RMA, you give them a CC# and they hold the money against the card until you return yours then its credited (if they charge it at all, they may just hold the # in case you dont return the bad one.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...