Jump to content
Corsair Community

Can't install H60 screw turns forever


Tiako

Recommended Posts

Tiako, Yes you may have one of those boards. You'll need to test the mounting to find the best position for the pump.

 

The main thing you need to do is change the standard mounting position of the pump, by turning it 90 degrees clockwise or counter clockwise so it clears any capacitors, etc, that are in the way. If you can't tell by just looking at it, you'll need to remove the thermal paste (since it will be ruined while testing the mounting position) and while trying another position, put the pump on the CPU and mounting posts and see if the same amount of threads on the four mounting posts are above the mounting brackets. You can gently push down on the pump with your finger to be certain it is contacting the CPU and is as far down as it will go. Once you find a position that works, apply the thermal paste and complete the installation.

 

Check the thread in the "Sticky" section at the top of this forum for a detailed discussion and pictures about this issue.

 

AFAIK, there has never been a board that will not allow a proper mounting of the pump, so just keep trying.

Link to comment
Share on other sites

Tiako, Yes you may have one of those boards. You'll need to test the mounting to find the best position for the pump.

 

The main thing you need to do is change the standard mounting position of the pump, by turning it 90 degrees clockwise or counter clockwise so it clears any capacitors, etc, that are in the way. If you can't tell by just looking at it, you'll need to remove the thermal paste (since it will be ruined while testing the mounting position) and while trying another position, put the pump on the CPU and mounting posts and see if the same amount of threads on the four mounting posts are above the mounting brackets. You can gently push down on the pump with your finger to be certain it is contacting the CPU and is as far down as it will go. Once you find a position that works, apply the thermal paste and complete the installation.

 

Check the thread in the "Sticky" section at the top of this forum for a detailed discussion and pictures about this issue.

 

AFAIK, there has never been a board that will not allow a proper mounting of the pump, so just keep trying.

 

That is good to know

Link to comment
Share on other sites

  • Corsair Employees
That cooler may not work with that MB it is hitting that row of Caps on the side of the CPU. You can try and rotate the cooler 90 Deg and test fir it to be sure it seats correctly, but if not I am sorry it will not work on that MB.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...