Jump to content
Corsair Community

H60 sudden grinding noise


ninposam

Recommended Posts

Hi first of all let me say how good i find this cooler way better than i could hope for.

 

Now onto my problem, i have had this cooler up and running for 2 weeks the first few days i had the normal noise i have read about on this forum... a sort of grinding data noise that after 2 or 3 days went away.

Now it seams to have come back? nothing has moved or changed in my case the only way i can shut it up is to tilt my case on one side but as soon as i move it back it starts again.

 

I have flicked the pump with the rad held above it to try and see if it was trapped air and that only made the noise worse, any ideas?

Link to comment
Share on other sites

Do those grinding noises sound like small marbles or bb's in the pump? If so, the pump is cavitating. Pumps cavitate when they are have insufficient suction pressure, which in the case of these closed loop systems is most likely caused by insufficient fluid in the system. I just purchased, but have not yet installed an H60. If I experience the same problem I'll get rid of the sealed system and go to one that lets me add fluid. I am very interested in Corsair's resolution of your problem. Hope you post for all to benefit from your experience.
Link to comment
Share on other sites

  • Corsair Employees
Yes that could be the issue and I would suggest moving the system in a different position while its running and see if the sound changes if it does then there is likely some air trapped in the pump and should work it self out in a few days, if not please use the link on the left and request an RMA and we can replace it.
Link to comment
Share on other sites

Ok, the noise sounds like a old HDD and as for running it in differen positions if i tilt the case to the right so the pump is facing up the sound stops if i tilt the other way so the pump is facing down it makes the same sound only 2 times louder!

 

Does seem a bit odd that this has started after 2 weeks of running.

Also Ramguy, if i did RMA it do you send a replacment first? as i dont have any other cooler and use my pc 90% of the day as i have a problem walking.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...