Jump to content
Corsair Community

High Temperatures H50 i5 2500k series


mR.Waffles

Recommended Posts

Hey guys I just replaced my processor and motherboard with a p67 and an i5 2500k series, and I put my h50 back on but I'm getting 60c under load stock speeds, without any over clock. This doesn't make sense. I've got a push pull going on as well. I cannot figure out what the issue is. I tried remounting twice. I'm using artic silver 5 and I followed their instructions to the letter: tinted the h50 base, dropped a line across the middle of the cpu and pushed the h50 on without spreading it with my finger, etc. Should I just skip their instructions and spread the artic silver all over the cpu? Is my h50 being a jerk? Is 60c normal under load with default 3.30ghz i5?
Link to comment
Share on other sites

So just a quick update. I accidentally flipped one of my push pull fans the wrong way so the air flow was pushing into the radiator from both sides. So I swapped it out, and rebooted, but my temperatures were still not as good as I expected (my old Q8400 ran at like 50c under load at 2.9). Anyway, here's where this gets weird. I said screw it I'll over clock and check temperatures. I pushed it up to 4.4ghz, from 3.3, and under prime95 load the temperatures max out at 80, and stick around 70. Seems like this chip just runs a little hotter. I checked out tomsguide and they said 70ish for a 4.4 over clock under prime95 load is fine. So I think I'm in the clear.

 

Seems like it runs medium hot stock, and just slightly hotter over clocked. Oh well, at least the over clock gives it a reason to be rather warm.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...