Jump to content
Corsair Community

Accessing Flash Voyager 32 GB on specific machine


The Mak

Recommended Posts

I am having trouble accessing my Flash Voyager 32 GB on my workstation. The drive works well on all other machines, and was working on my workstation just fine till one day I was copying over some files and the drive letter just disappeared. Since that time, every computer I had plug it into works just fine, except my workstation.

 

On the workstation (specs listed below) when I plug the USB drive in, this is what happens. The 'Safely Remove Hardware and Eject Media' pops up in the system tray. When I click on the 'Safely Remove Hardware' tray icon it lists the drive as '...'. Under Disk Management, it shows the USB drive as Removable 30.25 GB Online with the primary partition of 30.25 GB. I try the option 'Change drive letter and paths' but an error pops up saying Disk Management view is not up-to-date and refresh, and if that does not help restart Disk Management or the system. The same error continues after the refresh or restarts.

 

I had tried also removing the drivers, restart the system, and plug the USB drive back in. The drivers would install without a hitch but still the drive would not be assigned a drive letter and the same troubles will be present in Disk Management as I had described above.

 

I have also tried different USB ports on the back of the mother board and the auxiliary plugs that are meant for the front of the PC, but the issue still is present.

 

I have two other Flash Voyagers (4GB and 16GB) and this issue is not present with these drives on my workstation.

 

Again, the 32 GB drive did work on my workstation for quite some time. It was just that day that I was just copying files on to the drive (which I usually do) that the drive just disappeared and cannot be seen just from my workstation. All other machines that I have tried the drive on (XP, Vista, Win 7, notebooks and desktops) worked without any problems. My workstation has not had any problems accessing other USB drives or devices. It is only the Flash Voyager 32 GB drive. Any help would be appreciated.

 

 

USB Drive:

Flash Voyager 32 GB

Numbers on 'top' of USB plug: G32G NMC870269

 

Workstation:

OS: Win 7 Ultimate 64 bit (latest updates installed)

CPU: Intel Core 2 Quad Q9650 3GHz

Mainboard: EVGA 122-CK-NF68

Chipset: NVIDIA nForce 680i SLI

BIOS: Phoenix Technologies, LTD, Version 6, Sept. 4, 2008

 

Thanks in advance.

Link to comment
Share on other sites

My guess is you have blorked registry entries for that specific pendrive (the Flash Voyager 32 GB) in your workstation's registry. The easiest way to correct it is to use scrubber.exe (featured in MS KB277222) to remove all unconnected removable drives' entries from the registry. If you dont want to have to redetect the other two pendrives, it's easy: just have them connected to the machine when you run scrubber, and it won't remove their entries. Now, even if it's the easiest way, this is a multistep procedure, that requires patience. Morereover, I've done it before on XP and Vista, but always with the x86 versions of those OSes... so Win 7 x64 is unchartered territory. I'm willing to help you throughout the procedure. What do you say? Be warned it might not work, and that at least a restore point is needed to be created, before we start, since we're going to mess with the registry. Of course, a full backup is even better.
Link to comment
Share on other sites

Thanks dencorso, let me look into that tool and see if I can manage myself. I will post my progress and my findings. Thanks for the offer to help, if i run into any problems I will sure ask.

 

 

EDIT:

Well dencorso, I looked into that scrubber.exe, but I am not sure if it is for Win 7, but I did take a look in the registry. Here is what I have done so far:

 

Plugged in device that I had problems with and opened up Device Manager.

Under Disk drives can see Corsair Flash Voyager USB Device.

Plugged in my other working USB plug and saw another instance of Corsair Flash Voyager USB Device.

Opened up the properties of the first instance of Corsair Flash Voyager USB Device, went to details tab and compared it with the details tab of the other instance of Corsair Flash Voyager USB. They both look almost identical.

This appears to me that this is just the driver and thus cannot specifically identify the probelm drive in my machine.

 

Looked a little further down the Device Manager List and noticed that when plug in problem device a Storage Volumes entry pops up with Unknown device attached to its tree.

 

Opened up its properties and in details tab found "Device class guid" and "Device Instance Path"

 

Search for each in the registry and found both. The "Device class guid" did not show something that struck out as unusual. But the "Device Instance Path" had a registry entry that was different than my other Corsair USB drives. It was missing a "string" value as below:

Name: DeviceDesc

Type: REG_SZ

Data: @volume.inf,%storage\volume.devicedesc%;Generic volume

 

I went to add that value but an error appeared saying "Cannot create value: Error writing to the registry."

 

My gut instict tells me to just delete the folder in the registry that is identified by the "Device Instance Path". I figure it will just repopulate when I plug in the problem device. Is this a safe assumption? I know to be careful in the registry but this seems like the place where the volume is clearly identified.

 

 

ANOTHER EDIT:

 

I went to check the "Device Instance Path" in my netbooks registry and sure enough, the string value that was missing in my workstation's registry appears in my netbook's registry. My instinct to delete the workstation's "Device Instance Path" folder is growing stronger.

 

BTW what I mean by "Device Instance Path" folder is this location in my registry:

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\STORAGE\Volume\_??_USBSTOR#Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100#A140000000025448&0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}

Figured it would be easier to just say "Device Instance Path"

Link to comment
Share on other sites

Well, The Mak, I, for one, am *sure* scrubber is not intended for Win 7, and I said so.

My guess is that if you got the Server 2003 SP1 x64 version, and extracted it from the hotfix file with WinRAR, you'd be able to run it in Win 7, and it might do its job OK, iff (meaninig if and only if) the involved registry keys did not change between Srv 2k3 and Win 7. Now, if you're confortable with editing the registry by hand, then we can do that too, and you're in the right direction. When you insert any pendrive the go to the device manager and, under disk drives, look at its properties, the details tab will give you the pendrive's device instance's ID. One of my Corsairs has "USBSTOR\DISK&VEN_CORSAIR&PROD_VOYAGERGT&REV_1100\A1040127000XXXXX&0", where the Xs are numbers also. Now, if you copy the red number string, then disconnect the pendrive, and then search the whole registry you'll find it many times, but only two entries are relevant: the one at HKLM\SYSTEM\CurrentControlSet\Enum\USB\Vid_1b1c&Pid_1a90\A1040127000XXXXX and the one at HKLM\SYSTEM\CurrentControlSet\Enum\USBSTOR\Disk&Ven_Corsair&Prod_VoyagerGT&Rev_1100\A1040127000XXXXX&0 ...

You might export them to .reg files, just in case, to have a backup, and then delete them in the registry. After that, close regedit, count to 10, reinsert the pendrive. I bet it'll be redetected and will start working again. Of course, as always in life, YMMV... but my bet is it'll just work.

Link to comment
Share on other sites

Thanks for the quick feedback and sorry for the late response.

 

RAM GUY:

 

Performed the format with the provided tool on another PC, but my workstation still has the same problem.

 

 

dencorso:

 

Found the relevant registry entries you suggested, exported a copy of each, then went to delete, dialog box came up saying "are you sure you want to delete the key and all sub folders", click on yes, but an error came up saying "Error Deleting key".

 

I was running regedit with admin privileges so I am not sure what could be the problem.

 

I have not had much experience editing registries in Win 7/Vista, most of my time has been spent with XP. I do not remember any time under XP registry editing where it would not allow me to make changes (as an admin), but I have never messed with registry entries for hardware. Is there some protection that I am not aware of?

 

Well just went and created a new key under HKLM\SOFTWARE and deleted it successfully. When I tried to create a key under HKLM\SYSTEM\CurrentControlSet\Enum\USB\VID_090C&PID_1000 it says I do not have the requisite permission to create a new key. There appears to be some write protection for hardware entries.

 

 

 

EDIT

Did a bit of searching and found out that registry settings have permissions (right click on a registry key and there is a Permissions option in the menu). It seems that anything in or a sub-directory to HKLM\SYSTEM\CurrentControlSet\Enum does not list the Administrators with any permissions. When I try to add the Administrators group (and set the allow full control permission) I get the error "Unable to save permission changes on Enum. Access is denied." :( Back to google I go.

Link to comment
Share on other sites

  • Corsair Employees
That sounds more like an issue with the USB controller or driver its using on the MB, check for the latest MB BIOS and drivers for the chipset and. You might try and re-install the USB mass storage drivers on that system with no other USB devices connected.
Link to comment
Share on other sites

Try running regedit as system. Here's is an explanation of how to do it in XP and Vista. I don't have the slightest idea of whether that way still works in 7, let alone 7 x64. Then again, if that doesn't work, the concept of running as system is the way to go, and there should be a method that works for 7 x64. Another idea is RunAsSystem, a freeware from Qwertylab. Also, xregdelkey is another tool that may be of relevance to solving your problem.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...