Jump to content
Corsair Community

800D expansion bay problems


wkjones

Recommended Posts

I am having a problem with the toolless expansion bays. The Front pins on two bays are stuck in the lock position, with the toggle being in the unlocked position.

 

Is there a quick way to fix this, or is there a way to just remove the toolless part off the case? I don't mind using good old fashion screws.

 

Thank,

Wkjones

Link to comment
Share on other sites

Try using a flatblade screwdriver to push the pins back from the inside of the drivecage. It may be that paint has caused them to stick in that position.

 

If that doesn't work, you can remove the plastic slide. Be warned that doing this properly will likely damage the finish of your case, since you'll either need to flatten the piece of metal used as a slide-stop or lever the plastic slide over it. If you take a look at the end of the slide (while in the unlocked position) furthest from the front of the case, you'll see what I mean.

Link to comment
Share on other sites

I thought about taking it off that way, but i was way to afraid of damaging the brand new case. I don't think it is the paint but it seems to be that the spring isn't sprung back far enough.

 

I waited to long before i found this problem for warranty from the place I bought it and I don't know if corsair would cover this or not?

 

Thanks

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...