Jump to content
Corsair Community

Looking for a USB 3.0 Front Header Cable


jewie27

Recommended Posts

I just bought a Corsair 600T case and want to know if Corsair will make a front header cable that attaches to the motherboard. At least something that will at least convert the included usb cable to a header plug. If not, can anyone suggest where to get one? I don't want to pass the regular USB 3.0 cable out the back of the case, it looks unprofessional and sloppy.
Link to comment
Share on other sites

riverspiv: That's not quite accurate. The new Carbide cases have motherboard connectors for USB 3.0.

 

Not to mention that I said "anyone who has a Corsair case". To my knowledge, the Carbide cases are not available yet to the masses so nobody really "has" those cases.

Link to comment
Share on other sites

  • 5 months later...
Well regards to the new cases having USB 3.0 headers I got mine yesterday and its pretty much a USB 3.0 passthrough to the back of the MB which is a pretty bad show. Maybe I just got old stock, who knows. Either way the case is advertised as supporting USB 3.0 which clearly it does not, I could have gunthered a passthrough myself -.- a 20pin to usb 3.0 converter in with the bag of tricks inside the case whould have been a nice idea.
Link to comment
Share on other sites

So I picked up this one for the usb 3.0 http://www.amazon.com/HDE-2-Port-USB-Female-Adapter/dp/B0064B7IYU/ref=sr_1_16?ie=UTF8&qid=1327175608&sr=8-16

 

It works for now until something else I like better is made. A pic of it in my 800D(bad cell phone pics but you get the idea).

http://i40.photobucket.com/albums/e216/kevinjsess/2012-01-21_12-44-16_251.jpg

http://i40.photobucket.com/albums/e216/kevinjsess/2012-01-21_12-40-26_449.jpg

http://i40.photobucket.com/albums/e216/kevinjsess/2012-01-21_12-40-41_908.jpg

Link to comment
Share on other sites

So just a heads up on an update from my last post with the usb 3.0 adapter. The adapter caused my usb 3.0 to stop working yesterday out of nowhere(even the 3.0 slots on the back of my mb). I tried even reinstalling my drivers and no luck. Removing the adapter fixed my issues. I would guess its not the best of quality at this point but maybe others will have better luck with it.

 

Kevin

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...