Jump to content
Corsair Community

SP2500 no mid-range and crackling plug


MaDMaXX

Recommended Posts

So all the reviews suggest great mid range etc etc, but i'm having great trouble with most music and games especially. Highs are great and clear, the bass is, well, thumpy, not much there, it either sounds separate and too much or not there at all (due to trying to turn it down to stop it sounding too much)

 

I have to twist the sound cable (plugged into the sound card) round to stop the sound crackling.

 

 

Any ideas, i can't believe this is premium audio, my old Altec basic speakers had more mid range.

Link to comment
Share on other sites

  • Corsair Employees
Yes actually I do our speakers have a ton of mids; where they lack like most computer speakers in in the upper Mid area. However, they are better than any other computer speakers I have heard and for reference I am a musician and have access to all kinds of speakers and use a set of Mackie Studio monitors and Subs for my stereo which also connected to my computer, What can I say I like my Ted Nugent and A/C D/C Turned up and before we released these speakers my opinion was given to the PM based on this configuration as a reference. So I really think its either a setting on your side or the cables and since we know there is a cable issue lets try that first
Link to comment
Share on other sites

Ok thanks, I submitted an RNA for the cables, have you had this kind of problem with cables before?

 

Thanks for the replies, I don't believe its a setting as I used to work on sfx before I had to give up nicer speakers a year ago. Looking forward to a rich sound, I'm wondering if its a bass box problem? Can this be tested using late night mode?

Link to comment
Share on other sites

I've not had any response back re the RMA yet, also not had an email with the number in it.

 

Tried speakers again last night, other than cutting off the bass box, late nigh mode didn't make much difference.

 

The speakers sometimes sound ok and at other times severely miss the mid part of the sound out, leaving the bass sounding odd and over done, playing bass it shouldn't.

Link to comment
Share on other sites

Well, friday night, halfway through a game, all sound cut and i got a high pitched whining instead. Stopped everything, restarted the computer and the speakers, now it's a low pitched buzz.

 

Removed the speakers and plugged them into my phone, barely any sound level coming from them and the buzz still emanating.

 

Speakers unplugged and volume turned up to 25% or higher and they will produce a similar buzz.

 

Confirmed sound card ok with headphones and old speakers.

 

So they lasted 3 to 4 evenings of use :(

 

I'm guessing RMA, but this is fairly annoying and i guess explains the missing mid range, they're practically nothing from the bass box now, you can just about hear the sound through the buzz if you turn the speakers up to 50% or higher.

Link to comment
Share on other sites

Ok, RMA issued, slightly annoyed i have to wait for the product to get back there and tested before sending the new one out. I waited a month to have this thing shipped and now it'll be close to two weeks time i get it back.

 

Please tell me this is pre-paid shipping, i've only had the speakers 3 days before they blew up!!

Link to comment
Share on other sites

Thanks Ramguy, I've done that and they kindly offered both advance shipping and to pay for it.

 

However, with them being out of stock with yourselves, they suggested to contact the reseller, in this case amazon.

 

The good news is that they're accepting the return, sending in stock speakers out right now and a pre-pay label to ship the faulty speakers back.

 

Ramguy, thanks for your help, i hope the new speakers fulfill my exceptions for these speakers :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...