Jump to content
Corsair Community

question about H50


Youngd8

Recommended Posts

Can I RMA h50 if my radiator screw holes are loose?

I can't even mount my fan to the radiator anymore.

I thought these things were made to last. I was trying to test out different fans for the best results and next thing i know screws dont tighten...

 

btw i got my hands on scythe gentle typhoons ap-15s!!!! AMAZING fans with lots of static pressure and quiet too

Link to comment
Share on other sites

Can RAM GUY or any other moderator please check what my rma status is on 2109163.

I Really do not understand why I have to post this on the forums every couple days when Corsair States their RMA processing policy on their website. Is this just for show or something?

"•All RMA requests are reviewed and confirmed within one business day" Didn't happen AGAIN

Got an confirmation e-mail saying my rma request was received on 6/24/2011 5:03 PM.

I should've received an response today but didn't.

Link to comment
Share on other sites

  • Corsair Employees

Forum Mods cannot access that system only direct corsair employees.

And I have sent your request to customer service, if you do not hear from them by this time next week I would suggest calling our customer service.

But they are about 5 days behind in parts requests sorry!

Link to comment
Share on other sites

Can I RMA h50 if my radiator screw holes are loose?

I can't even mount my fan to the radiator anymore.

I thought these things were made to last. I was trying to test out different fans for the best results and next thing i know screws dont tighten...

 

btw i got my hands on scythe gentle typhoons ap-15s!!!! AMAZING fans with lots of static pressure and quiet too

 

My did the same thing on 2 of them.

Link to comment
Share on other sites

  • 2 weeks later...

Well just wanna give you guys an update.

I got my Rma today and surprisingly corsair sent me a h60 for a h50 rma.

They said they dont have any h50 anymore.

Happy camper here.

oh yea i think its my sensor or something but it's reading my pump speed at 4200rpm lol

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...