Jump to content
Corsair Community

CMPSU-950TX - Frying parts


PHASER8

Recommended Posts

Hey guys,

 

Got a real problem here, it seems my Corsair power supply I bought from Newegg might be frying parts, specifically motherboards.

 

I bought all my main rig parts back in March (these are the first set), the entire system stopped working 40 days later:

 

AMD 1090T CPU (Not OC'ed)

Sapphire 6950 Video Card

Gigabyte 890FX-A UD5 AM3 motherboard

GSkill Sniper Memory 8GB (F3-12800CL9D) (2 4GB sticks - DDR3)

(Various Western Digital Hard Drives)

Lian Li P80 Case

 

 

Second motherboard was an ASRock 770 Extreme3.

 

Now to give you an idea of what is going on, about 40 days into this build I come home from a long day of work to find the machine powered off. (I never power my machines down except during storms, they are hooked to a very large and expensive UPS that handles any power surges or brown outs).)

 

I hit the power button and nothing. I cycled the hard power switch on the PSU and still nothing, at this point I opened the case up to find the lights on the motherboard buttons on (this motherboard has bench buttons for power, reset and clear CMOS). I hit the power button and nothing. Cleared the CMOS both with the button and manually, nothing.

 

Turns out though, if I unplugged the 20+4 pin power connector on the board and plugged it back in and hit the onboard power button, the machine would boot but lockup and require a hard power down.

 

I spent two days trying to get the machine to work (finals were coming and I am a dual CS major, BIG projects ahead). I thought it was the motherboard and tried to have Newegg take it back and overnight me a new one, all at my expense...they wouldn't budge one bit because it was too far past the deadline. Tried Gigabyte and they screwed me too...Long story short, bought a new Motherboard...ASRock and paid $40 or so for overnight shipping to get it here.

 

Well about a week later I decide to throw the GIgabyte board that I thought was dead/fried into another case with a spare power supply. I had no memory or CPU for it and thought, what the hell..lets power it on. Plugged a THermaltake PSU into it and sure enough, was able to power it on and off without any lock ups....Then decided to bite the bullet and buy a CPU for it, $100 later and a memory swap on my working system...I come to find out the Gigabyte board is back up and working. I never thought any more about this.

 

Fast forward till today, come home and SAME THING. Go through the steps and I am really upset. So I decide just to swap things out and low and behold, the working Gigabyte board fails to power on while on the bench with the Corsair PSU..Switch it back to the other and it works.

 

Swap the ASrock board to the other PSU, now dead. Here is the kicker though, I pulled another motherboard out that was working and plugged it into the Corsair PSU and it works.

 

It seems the Corsair PSU is doing SOMETHING over time to the motherboard causing it to fail, but after about a week when this first happened the first board (Gigabyte) never had any more problems on a different PSU.

 

Anyone experience anything remotely like this? I'd like to get a warranty replacement on this thing but I am now kind of worried about using or suggesting these anymore if they can cause these issues, if this were to happen to one of my clients then I could lose money or even worse; the business of the customer.

 

 

Any suggestions?

 

Thanks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...