Jump to content
Corsair Community

Corsair USB Flash Drive 16Gb Write Protected Error


Ravanelli

Recommended Posts

Hi all,

 

I need your help with my USB flash drive. It says it is write protected... It has no switch and I've tried a lot of solutions I found in Google, however, they didn't work. Tried formatting with HP USB Disk Storage Format Tool, with Hard Disk Low Level Format Tool, and with SDFormatter...

 

Can you guys help me out?

 

Best Regards,

RP

Link to comment
Share on other sites

  • 2 months later...

I had the same problem - trusted corsair 8gb usb suddenly decided it was write protected. (Btw, I think the cause may have been filling up the disk.)

 

Anyway, I tried *everything* to no avail, until ... the JetFlash Online Recovery tool available for download at the bottom of this page http://REMOVED worked for me.

 

With the 'format and keep data' button I still lost all my data, but formatted my *less* trusted usb stick

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...