Jump to content
Corsair Community

H60 Intel bracket came with a damaged paintjob!


Recommended Posts

When I recieved my Hydro H60 on the 4th of May the Intel bracket that came with it had a damaged paintjob, I'd like a replacement because it looks ugly through my pc window.

 

So I tried contacting the customer support 3 times but i didn't get a response, finally the 4th time i did, now they want me to send my whole H60 to america! I'm from the netherlands and that will take ages!

 

Also i cant use my pc if i ship it, so why cant you just send me a new bracket??

 

If you dont have the parts just open up a new H60 and take the Intel bracket from there.

 

Here are 2 pictures:

 

http://www.mediafire.com/?0t104jdn33tpnqf

http://www.mediafire.com/?ymt499x779219ll

 

Please send me a bracket, i want to install it onto my sandy bridge!!!

Link to comment
Share on other sites

You're wrong, as the install guide says you put the backplate on the back of your mobo then you put in the stand-off screws and place the H60 ontop and twist on the thumb screws.

 

The brackets shown on my picture are the one's that come attached on the h60 when unboxing, but if you use AMD you can take them off and put on the AMD brackets.

 

Can you send me the bracket please?

Link to comment
Share on other sites

Oke I got back a reply and they still want me to RMA my product:

Based on the information you have provided, the best thing to do is send us your parts for replacement.

 

Does this mean they want me to send the damaged bracket to them and as soon as they recieve it they will send me a new bracket?

 

Why do you want me to send a piece of metal all the way to America? Can't you just send me a new bracket straight away?

Link to comment
Share on other sites

Oke it says RMA assigned, now they want me to send the 'defective parts' again.

 

Can you please fix this, and make sure they will ship me my brackets as soon as possible.

 

I just want to get the brackets and install the H60 onto my new mobo, why do I have to send that stupid peace of metal back to America before I can get a new one?

 

And I'm not even sure if the RMA guys know which part I need.

Link to comment
Share on other sites

  • Corsair Employees

Danny2011

I am sorry but I have tried to make you understand from the beginning you have to fill out the RMA request to get the order in place for the parts to be sent you. Once you fill out the RMA most of that system is Automated and yes you will get some emails that do not make sense in your case because you do not need an RMA. But there is no other way in the system to get your address if you do not provide it. And as we have stated several times if you would contact our customer service they would be happy to explain all of this...

Link to comment
Share on other sites

I did submit for an RMA when you told me to, I also filled in my address, and I did contact the customer support yesterday (rma@corsair.com) but I still haven't recieved a response yet.

 

The thing is that I've contacted the customer support several times and I didn't get a response, so after I used a different E-Mail address I finally did got a response but unfortunately this takes really long.

 

So I've done everything you told me to, what shall I do next?

Link to comment
Share on other sites

  • Corsair Employees
I am sorry but you would need to call them by phone if you have more questions or you do not feel they are answering you, you can get the phone number under CONTACT on the main site.
Link to comment
Share on other sites

First they didn't reply to my previous E-Mail address and now they don't reply to this one neither.

 

I want the Intel bracket to be sent to me, I've done everything you told me to and I'm tired of waiting.

 

Make them send me the bracket, maybe you can contact them for me.

 

I'm disappointed in your Customer Service......

 

Just get me the stupid bracket PLEASE!

 

Edit: And I'm not wasting any money on making a phone call to America.

Link to comment
Share on other sites

  • Corsair Employees

I have sent them a message and called them on the phone for you that is about all I can do sorry!

I just spoke with Kelvin D and he has been speaking with you in email and had explained that we did not have that part to send you the only way would be to replace the unit. However, they just got the parts in and have arranged them to be shipped to you. Again you need to contact our customer service complaining here does not help. Sorry!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...