Jump to content
Corsair Community

HX850 High pitch sound


ulle

Recommended Posts

Hello!

 

I've just bought a Corsair HX850 PSU but it has this high pitched sound coming from it when the PC is turned off, but PSU switch turned on. The noise disappears as soon as i turn on the computer.

 

The sound is noticable enough to be annoying, even with the pc case closed up.

I've read some other users on this forum have had the same issue, so i was thinking of getting an RMA. Should i do this with the dealership I bought it from, or directly with you guys? (Bought it 1-2 weeks ago)

 

Thanks in advance, best regards

 

Julien

 

EDIT: Also i was wondering.. If i decide not to do anything about it, will this affect any of my other components? And does this sound mean I have a PSU with a shorter life span?

Link to comment
Share on other sites

Take a look at the very first "sticky" at the top of the PSU section here and follow those steps. If you decide to RMA the unit then that is entirely up to you who you want to deal with. If your retailer is local i would try them first just because of less turn around time. If you decide to RMA direct through Corsair , of course it will take a little bit longer.

 

EDIT: Also i was wondering.. If i decide not to do anything about it, will this affect any of my other components? And does this sound mean I have a PSU with a shorter life span?

Highly unlikely.

Link to comment
Share on other sites

Take a look at the very first "sticky" at the top of the PSU section here and follow those steps. If you decide to RMA the unit then that is entirely up to you who you want to deal with. If your retailer is local i would try them first just because of less turn around time. If you decide to RMA direct through Corsair , of course it will take a little bit longer.

 

 

Highly unlikely.

 

Ofcourse ive read and tried everything at the first sticky post :)

 

After having the PSU for a while now, I dont really notice the sound anymore, so i guess im just gonna keep it. It also seems the sound has gotten abit lower anyways. And the sound is actually more intens just a minute or two after ive turned the PC off.

 

I just hope it doesnt fault after a short while..

 

Thanks for the help, best regards

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...