Jump to content
Corsair Community

Corsair Force F120 BSOD then apparently dead/bricked


kh657531

Recommended Posts

Hello,

 

I appear to have the same problem as many others have posted here...

 

Built a new system with a F120 in February - see the specs in my profile. The F120 is the boot drive. It's on the first SATA port, and the BIOS is set to AHCI mode. I didn't need to upgrade the firmware since it was v2.0 when I bought it.

 

The system worked fine until last Saturday when it crashed and then STOP: 0x000000F4 BSOD'd on reboot. Since then, after a warm reboot, the BIOS pauses much longer than normal when detecting drives and fails to detect the SSD (but detects the other drives normally). On a cold boot, the drive is detected, Windows starts to load, but it only goes to the "Starting Windows" screen with the pulsing logo, and then reboots after a minute - so we're into the warm reboot scenario above.

 

One oddity is that when I cold boot from a Linux live CD (System Rescue CD), the drive is mountable and readable (at least the few files I've tried to access).

 

Switching the drive to another SATA port has no effect. In addition, attempting to reinstall Windows-7 from a cold boot (i.e. the BIOS detects the drive ok), the installer fails to detect the SSD. I also tried the drive in another computer and it just hung indefinitely during the boot process when detecting drives.

 

I assume this is an RMA scenario? RAM Guy, can I have your approval to tick your box on the RMA form?

Link to comment
Share on other sites

Hello. I just experienced the same issue as originally reported. Booting cold, BIOS splash screen is delayed, Starting Windows screen hangs. Rebooting and forcing "Start Windows Normally" allows me to boot normally. This occurs every other boot. I have used System Restore (3 day roll back) and it seems to run normally now. Should I be concerned with an RMA? Thank you in advance.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...