Jump to content
Corsair Community

Reactor R120 data corruption


bonze

Recommended Posts

Hi,

 

I live in France. I've bought a Corsair SSD Reactor R120 in may last year which has been configured as OS drive (AHCI enabled).

 

After one month I've noticed that some files got randomly corrupted (system asking for chkdsk, applications failure, pictures and/or sound files damaged, ...). After analysis, it appeared that file corruption only occured on my Corsair SSD drive. Files on other drive were fine.

 

Iv'e tried to reinstall another OS but it didn't fix anything. At that time I was unable to find decent help on internet and I was suspecting a combination of OS driver/Corsair SSD/Disk controller. So I upgraded my dekstop buying another motherboard to get rid of that issue. My pc was faster but of course it didn't fix the corruption issue.

 

Yesterday at last, I've found threads on this forum with other users dealing with the same issue (Note that I also have this other problem with the ssd drive not being seen sometimes during boot).

 

So right now, I would need help because I've already lost a lot of time and personal files (especially pictures which I didn't saved quickly enough).

 

Do all the SSD reactor have this issue ? If I can convince my local reseller to exchange my faulty drive with a new one, will I get corruption again ?

 

Is there any official statement about that issue so that I can convince my local reseller that my SSD drive doesn't work ?

Link to comment
Share on other sites

Thanks for the quick reply.

 

My original configuration was : Windows 7 (32bits) + Asus P5B Deluxe Wifi-AP.

The current configuration is : Windows 7 (64bits) + Gigabyte X58A-UD3R (Rev 2.0)

 

The Gigabyte motherboard contains 3 different controllers (Intel Southbridge, Marvell 9128, Gigabyte sata2), the Corsair reactor ssd is plugged in the port 0 of the Intel Southbridge.

 

I didn't install any specific driver, the driver for the disk is the OS driver included in W7. Its version is 6.1.7600.16385 (Win7_rtm.090713-1255).

 

Let me know if you need anything else.

Link to comment
Share on other sites

  • Corsair Employee
I would try the latest Intel storage drivers and make sure that you have the latest MB BIOS for your MB from the manufacturers site. If the problem continues please use the link on the left and we can try and replace the drive.
Link to comment
Share on other sites

Considering I have (had) this issue with two different motherboards, I doubt it will change anything with the latest Intel drivers and BIOS on the most recent MB.

 

Considering also that the second MB has been acquired very recently, I guess that my drivers are almost up to date (can't check right now, I'm not home).

 

I'm also rather reluctant to do that new test because it means another OS installation and configuration, applications re-installation and configuration, and another month to watch my system to detect if files will get randomly corrupt. Some files get corrupt but are not often used so I do not notice it. Some applications files get corrupt and suddenly the applications refuses to start, I suspect corruption but I'm not sure. Sometimes Windows ask for a chkdsk during boot, that is at least a logical corruption of the filesystem. Sometimes pictures and/or audio files get corrupt and I'm pretty sure about it because I can see it or hear it or verify it using a binary editor.

 

Considering I'm dealing with this situation since may 2010, I'm not sure I'm ready for another (useless) round. I use this desktop for work and not to play and this is a very incapacitating situation. Right now I put all my valuable files on my second drive (Velociraptor) to be sure they won't be compromised but I can't prevent my OS and applications to become slowly unusable.

 

The sad part in that story is that the nature of this issue (slowness of the process, randomness which does not simplify the analysis and requires time) delays its solution way too much.

 

Reading this forum it looks like I'm not the only one to have this issue (as mentioned in my first post, I also have this other issue with the drive not beeing seen by the BIOS sometimes during the boot but luckily I only have to restart it to get it work and it doesn't destroy my data)

 

Is there any other option that I could try instead of re-installing everything with the latest intel drivers and MB BIOS ?

Link to comment
Share on other sites

I've checked my system and my Intel Rapid Storage drivers are up to date. The BIOS version was FB (august 2010) and the last one is FE (december 2010).

 

As I said earlier I had already that issue with my previous MB so the probability that the corruption is linked to a driver is in fact very low.

 

My own conclusion is almost the same than yours but slightly different : if my drive is replaced with another reactor and if it is a drive design/firmware issue then it won't solve my problem.

 

Reading the other posts about that topic it looks like Corsair is not able to recognize that at least some drives are faulty. I don't know if only a serie of drives is affected or the whole batch but I do not trust that reactor anymore.

 

I've build laptops for years and I work as an integration engineer in a SAN environment. I work everyday in a lab building configurations involving multiple OS, multiple protocols and multiple disk arrays from different vendors. I do not say I'm qualified for drive testing but from what I've seen and experienced at home with that reactor, I'm pretty sure it doesn't work properly and it is not a driver issue.

 

Right now I see only two options:

 

1/ Corsair (or my local reseller) replaces my faulty drive with another DIFFERENT model and I'm ready to forget about those personal data and all that time I've lost dealing with that problem.

 

2/ No one cares about it, I have to sit down on the 300 euros I've paid for it, and I won't buy Corsair hardware ever.

Link to comment
Share on other sites

Often times when there is corruption on a drive it is the controller malfunctioning. I had a drive in a RAID 1 array on a Marvell RAID controller and always had problems. When I moved the array to an ICHR all my problems were solved.

 

I would backup all the data on the drive and then send it in to get a replacement. When you receive the replacement secure erase the drive and then try again with an Intel controller and do not use a RAID config. Just use the Intel RST drivers (not the matrix storage) or use microsoft AHCI.

 

Make sure your BIOS is set to AHCI before anything.

Link to comment
Share on other sites

Thanks for the contribution.

 

I didn't use any RAID configuration, the reactor is my C drive and I had my old velociraptor as D drive.

 

AHCI was set before anything on every attempts I've made (the ones with my old Asus MB and the ones with the new Gigabyte MB)

 

My local reseller has accepted to replace the reactor with a fresh one (I'm still in the warranty period), I guess I will sell it because I've already bought another vendor SSD to use as C drive.

 

End of story and big disappointment.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...