Jump to content
Corsair Community

2 x F60 with RAID 0, TRIM???

Recommended Posts



i have 2 x F60 (with CSSD-F60GB2-BRKT product code) and Raid 0 them.


My motherboard gigabyte x58a ud7, bios version F8B


i used XHD ( extreme hard drive) in bios to raid and installed windows 7 x64.


Installed the other motherboard drivers with its CD.


after those steps

i check TRIM,

"fsutil behavior query DisableDeleteNotify" answer is "DisableDeleteNotify = 0"


But there is not any certain information about TRIM command with Raid.






please answer cetainly, or silence...



i fed up with inadequate informations any where...

Please a certainly answer.

Link to comment
Share on other sites

Yes, but it's not what you think.


YES, the OS has TRIM turned on.


NO, the TRIM commands do not reach the SSDs due to the RAID controller making the OS think it's one large drive. To the OS, the RAID storage is not capable of TRIM.

Link to comment
Share on other sites

hello again,


i have search and find some infos that the driver "RAID: Intel® Rapid Storage Technology Driver for Intel Desktop Boards" has accept TRIM commands.


Drivers URL: http://downloadcenter.intel.com/detail_desc.aspx?agr=N&ProductID=&DwnldID=15251


is it true ? if so how to install this driver ?


Infos say that

Thankfully, Intel has solved the problem with the release of a TRIM-compatible driver which finally brings the technology to SSDs in RAID arrays.

Available over on Intel's website the new Rapid Storage Technology driver allows users of selected Intel motherboards to enjoy the benefits of RAID without losing the benefits of TRIM support.

Link to comment
Share on other sites

The latest RST driver from intel can be located here:




TRIM is only supported through IDE and AHCI. AHCI uses the same driver as raid but the TRIM command will not pass on a raid setup as the controller does not support TRIM under any raid conditions.


You use Idle Garbage Collection to restore performance on a setup that can not run TRIM. To do an Idle GC first make sure that under power management options turn off hardrive is set to never. Next step is to simply log off the PC or reboot into the bios and let it sit for many many hours.


The Sandforce controller has a very poor method of Idle Garbage Collection, you may need to let it sit for as long as 24hours in some cases.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...