Jump to content
Corsair Community

Corsair Dominator Won't run at 1600mhz


Recommended Posts

So Ive put together a new computer , i7 950 , EVGA x58 Ftw3 and Corsair DDR3 1600.


Everything worked fine and all. I used XMP and also tried my own settiings ( 8-8-8-24 /1.65v)


Then when i run OCCT medium , I'm getting a hard lock everytime or a bsod (win32.sys / System_service_exception)


I down clocked the ram to 1066 and ran occt , Went all fine.


I ran Memtest on each stick , and then all 3 together , No errors.


Tried again XMP and i'm getting a hard lock again. I'm so lucky getting those stupid memory stick to run at rated speeds. I'm getting tired of memory stick that doesn't run well. Last time it was my 1066 mem with my old Motherboard But i thought it was cause the mobo sucked , and the memory too. And now that i spend 250$ on a motherboard and 160$ on memory sticks. I would've thought it would run at the rated speed. Anyways Its late so sorry for the grammar errors and my frustration xD


So if anyone is kind enough to help me , It would be greatly appreciated.


Also , Happy new year.



Link to comment
Share on other sites

also the ram number is TR3X6G1600C8D 1.65v


I'll do further investigation tomorow . I just couldn't go sleep till i resolve that one.


Im gonna drop the CPU VTT till i get hard locks again. So i know the limit.


Anyways i'm planning to Overclock my CPU soon so.. Everything's gonna change pretty much. I just wanted to know if i had faulty ram / Mobo

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...