Jump to content
Corsair Community

F120 no longer detected by bios


Recommended Posts



I have a huge problem with my only 3 month old Corsair Force F120.


The SSD could not be detected from the bios of my notebook any more. The drive-LED is on all the time, that isn’t normal. The bios shows a message like “Insert a boot device and restart.”

Also the bios from my desktop-computer can’t detect the SSD. (At first the bios stoped. Now the bios do not detect the SSD and is booting normally without detecting the SSD.) I tried both controllers (nVidia and Silicon Image).

And also I can not access the SSD via USB. (In a external drive case connected via USB.)


The defect appears when I try to start the Notebook (or also desktop).

I worked with my Notebook (Win7 installed) and put it to hibernation like normal.

After 30 minutes I wanted to restart my Notebook at home to make the Backup of the work and than the “**** happens”. The SSD no longer is detected by the bios.


The Notebook is an ASUS V1JP.

There was no problem, no bluescreen, not a hint that the SSD would have a failure before the SSD crashed.


I hope you can help me an there is a way to repair the SSD or bring me back my Data on another way.

Link to comment
Share on other sites

This is the same problem I had with my laptop. A warm reboot often fixed the problem in the short term. What I did that seems to finally have fixed this problem was to:


1. Upgrade to the latest BIOS

2. Make sure you are in AHCI mode

3. Upgrade the SSD to version 2.0. I used a WinPE bootable USB drive to do the upgrade.


4. Download and install Windows Automated Installation Kit (AIK) for Windows 7

a. Go to Microsoft and download the iso image, make a CD and install

5. Make USB bootable WinPE

a. http://4sysops.com/archives/build-a-bootable-windows-pe-3-0-usb-drive-with-rescue-tools-part-1/

b. http://4sysops.com/archives/create-a-bootable-windows-pe-3-0-usb-drive-with-rescue-tools-part-2/

c. Documentation: http://technet.microsoft.com/en-us/library/cc749538(WS.10).aspx

6. Gather third-party tools for USB bootable WinPE

a. PStart a portable Windows launcher


b. Q-Dir a portable Windows Explorer



7. Upgrade the IDE/ATA driver to Intel RST



Sorry for the questionable organization of this post. This is what I did and I believe all my boot problems are gone. I never had the sleep problems described in this forum.

Link to comment
Share on other sites

Hi rhesuspieces,

thank you for your answer.


There are some "problems" for me:


1. BIOS is the latest

2. BIOS don't show me the option to enable AHCI, I worked in IDE-mode all the time in the last 3 month an it worked fine.


I hope I can do all the steps you explained 3. ... 7.


I'll try my best to get my data back.

Link to comment
Share on other sites

Nothing you can do at the OS level will help if the BIOS doesn't see the drive.


Attach the drive, if the machine doesn't see the drive at boot try a warm restart. That worked for me when my machine didn't see the drive.


Once the BIOS can see the drive, try the upgrade of the IDE/ATA driver to the Intel Rapid Storage Technology (RST)

Link to comment
Share on other sites

  • 2 weeks later...


Sadly I had no time since new year to have a look to the SSD. But now I have a little bit.


Thank you for your answer rhesuspieces.


That was one of my questions I got over the time.

Is it possible to "3. Upgrade the SSD to version 2.0. I used a WinPE bootable USB drive to do the upgrade." i the SSD isn't detected by the bios? I don't think so. Or am I wrong?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...