Jump to content
Corsair Community

F40 and win7 x64

Recommended Posts



i just got my first ssd (yay!) but i've ran into some problems with the windows installation. the setup completes and reboots, finalizes and reboots one more time. everything seems fine until this point. the system boots normally and shows me the windows 7 bootscreen ("windows is starting") but after that it stops (no video input, and the monitor goes to standby). all i can do at this point is reboot, when i try to run safe mode, it tells me to restart to complete the installation.

the funny thing is that ubuntu 10.10 works like a breeze on that same disk. i figured i'd maybe need f6 drivers for the intel raid, but win7 as well as ubuntu seem to recognize the drives (raid+ssd) just fine. hmmm. i've also tried to plug the ssd to other onboard sata-ports (jmicron/ez raid), but the behavior stays exactly the same.

i have not flashed my bios or ssd yet, do i have to?

can anyone help me out?




Link to comment
Share on other sites

hey, thanks for your quick reply. it took me quite some time to try out your suggestion. here is what i did:

- drive was listed as "frozen", so i did the hotswap-thing

- secure erase (internal)

- reinstalled windows

nothing changed.

so i:

- plugged the drive to the first sata-port, unplugged all other drives

- flashed the mainboard's bios to the latest version

- tried out several bootsticks

- created boot images under win7 and ubuntu

- tried fat32 and ntfs for the stick(s)

- tried out 32/64bit versions of win7

- tried different bios settings (raid, ahci) and different sata ports/onboard controllers


both windows install images are legally downloaded msdn versions and were also tested on another pc without any issue.


ubuntu still works fine, the win7 setup recognizes the f40 and the setup seems to work normally until after the first reboot. at that point, i get "no display signal" instead of the login screen.


hmmmm.. is there anything left i could try?

Link to comment
Share on other sites

  • 1 month later...

hmm, there are the "intel® chipset drivers" on the p5w driver page, though i have to admit that i've never seen a noticeable effect after the installation..


do you have any idea what could be the issue with my configuration? the drive works, and win7 recognizes it when i boot from another drive. i tried all possible sata ports/modes. the installation i did on my computer is fine too, i just moved the drive to another pc and it started without issue. when i put it back into my pc, i get "no input signal" after the "windows is starting up"-screen.


you are using sata port 1 and ahci, right? i'm starting to think you were right all along, the video card may be the problem.. but then why is it working out-of-the box with a regular hdd, the standard win7 video drivers must be the same..?

Link to comment
Share on other sites

  • 6 months later...

better late than never, i guess.


it seems win7 (sp1 version as well) can't finish the installation when i have my monitor connected via dvi (at least on my system). go figure.


my solution was to use a dvi-to-vga-adapter and a vga cable to complete the installation, install graphics drivers (latest catalyst, in my case), and then switch back to dvi cable without adapter. works perfectly now, corsair and their fine ssds are completely innocent!




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...